White smoke from exhaust, no loss of coolant - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-07-2012, 02:32 PM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2012
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation White smoke from exhaust, no loss of coolant

I have posted in the engine forum with no luck. I have white smoke coming out the exhaust with no loss of coolant and no apparent loss of oil. I had the truck diagnosed at the dealership and they said everything looked good but that it could be the egr valve. I replaced it with no luck. I spoke to the mechanic and he said it was not the injectors or the head gasket.

I am looking at the turbo seal this weekend and would like to know what to do next if that is ok.

Leopold is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome