bad egr valve? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-03-2012, 07:18 AM
Powerstroke.org Rookie
 

Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bad egr valve?

My truck has been running pretty bad lately, it has a whiteish/blue smoke and occoasionally (when acceleration) puffs black smoke. It all seems to be intermittant, cant seem to produce the symptoms. Today after fueling up and leaving the station the truck stumbled really bad when accelleration (all the way home, approx 3 miles) and at times smoked out the cars behind me with a whiteish smoke. The truck is throwing the P0405 code which says a problem with the EGR system. Would an egr problem cause the truck to run this way? What else could the problem be?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-03-2012, 07:30 AM
Premium Member
 

Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,952
Thanks: 0
Thanked 33 Times in 31 Posts
Feedback Score: 1 reviews
Start out simple, pull the EGR valve and see if it needs cleaning.
Reply With Quote Quick reply to this message
  #3  
Old 11-03-2012, 07:42 AM
Powerstroke.org Rookie
 

Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Pulled the valve couple weeks ago and didn't look bad...
Reply With Quote Quick reply to this message
  #4  
Old 11-03-2012, 07:46 AM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 17,128
Thanks: 13
Thanked 48 Times in 37 Posts
Feedback Score: 4 reviews
stuck or sticking EGR valve can definitely cause these symptoms.
Reply With Quote Quick reply to this message
  #5  
Old 11-03-2012, 08:39 AM
Powerstroke.org Rookie
 

Join Date: Nov 2008
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Took it out and cleaned, still dust look too bad... Will advise results after driving for a bit
Reply With Quote Quick reply to this message
  #6  
Old 11-03-2012, 05:59 PM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 17,128
Thanks: 13
Thanked 48 Times in 37 Posts
Feedback Score: 4 reviews
It could be bad electrically. It's basically a big solenoid, so the internal windings get weak or go bad completely.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors