Hard start, black smoke, white smoke and dead battery - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-27-2012, 04:31 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2012
Location: New Port Richey, FL
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hard start, black smoke, white smoke and dead battery

Ok, my boss has an 06 powerstroke and has just recently started having problems with it. The other morning it would not start, all lights were bright but we put a charge on it any ways. After about 20 minutes we got it started but it was super rough. So later that day we noticed low coolant so we filled it up. After driving it home and back the next morning, the coolant had disappeared. So we then took out the EGR valve and noticed goo in the manifold. So we think that problem is the EGR cooler but what about the hard start? Any advice.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-28-2012, 12:58 AM
Compression Ignition Addict
 

Join Date: Sep 2012
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would say that your EGR Cooler is shot. Anything in your egr valve besides carbon buildup is out of the ordinary and theres something wrong there. As far as the hard starts, it could be the EGR Cooler, or else it could be additionally a FICM and/or Injecor(s) going bad too.

Maybe someone can chime in if you can test the injectors safely with the egr cooler leaking.
Reply With Quote Quick reply to this message
  #3  
Old 10-28-2012, 07:34 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2012
Location: New Port Richey, FL
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thank you much
Reply With Quote Quick reply to this message
  #4  
Old 10-29-2012, 04:26 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,199
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Your hard starts are likely batteries and/or ficm. Bad batteries kill ficms. You need a monitor.......Write Up: Monitoring the 6.0L PSD.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:50 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors