Help. Getting run around at dealer!!!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-11-2007, 04:21 PM
Member
 

Join Date: Aug 2007
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help. Getting run around at dealer!!!!

I am Fairly new to the forum,but I love to read all the Good info all the members provide which helps alot. I have being having Problems with my 2005 Excursion I just purchased used in July .. It has 46000 miles and 20" with 35 toyo tires and I think 8" lift .and aftermarket exhaust ( havent being bale to figure out brand ) I am getting like a whinning sound from 2nd to 3rd gear when it shifts at normal driving. when I smash the pedal no whinning. So, took it to dealer and they replaced Selenoid body (Luckily bought the extra warrany for it )... Took it home and whinning noise stil there and now was also having very bad start when cold .. Took it back and I told them whinning never went away . Next day they call me that my aftermarket exhaust is the problem becuz very close to tranny and I had to tighten becuz also hitting dipstick and running very close to the Tranny lines.. So, I said ok .Got it fixed and took it a couple of days later.Next day the guy calls again and said that now the truck showed up a Programmer or chip in the computer which needed to be removed which could be causing my problems. I have not spoken to the forman in shop and i want to be ready for him . My bigger problem .I Have not had chance to install a programmer and if it does have one I dont have it !! I bought the truck in Phoenix at a dealer and I live in El paso,tx . Any advice of what I can do .
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-11-2007, 08:27 PM
Banned
 

Join Date: Apr 2007
Location: Ponca City, Okla
Posts: 1,089
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to Blue01F250 Send a message via Yahoo to Blue01F250
Well - first off -- your truck should be covered by a 100K mile/5yr warranty with a $100 ded

and i'm not sure if a reflash of the ecm would fix any programmers that are on there -- but make sure there isn't a chip actually mounted on the ecm.
Reply With Quote Quick reply to this message
  #3  
Old 10-11-2007, 08:38 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
honestly..ur noise could very well be normal for your rig......a more open exhaust will cause "whining" noises in 6.0's....a lot of people look for that...
Reply With Quote Quick reply to this message
  #4  
Old 10-13-2007, 07:54 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Posts: 4,556
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
call the dealer you bought it from and ask if you bought a "tuned" truck or if they know if it was stock when they received it.
Reply With Quote Quick reply to this message
  #5  
Old 10-13-2007, 07:58 PM
Click Click.......BOOOOM!
 

Join Date: Jun 2007
Location: Stoughton, MA
Posts: 326
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Which dealer did you take it too? Im also from El Paso.
Reply With Quote Quick reply to this message
  #6  
Old 10-17-2007, 07:59 PM
Member
 

Join Date: Aug 2007
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
getting run around

Sorry guys and thanks for you responses . I kinda strained my hand and a little hard to type with cast on I took it to shamaley for in El Paso Tx . I will be calling the dealer in phoneix I bought it from and find out if it was chipped before I got it . and aslo from my local dealer I will find out what code it pulled out that shows it has a programmer. Any other siggestions would be greatly appreciated . I totally regret getting rid of my 2000 EX and I really ready to cut my losses with this new truck ..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:34 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors