Mileage, PCM Flash, and White Smoke - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-07-2007, 07:44 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mileage, PCM Flash, and White Smoke

Hi. I bought a 2003 Excursion with a 6.0PSD in July. Since then, my mileage has been steadily decreasing, and it has been getting harder to start when it is cold. It takes about 3-5 seconds to crank over on the first start of the day, and it belches out a cloud of white smoke when it catches (then clears up immediately).

Here are a few details and background.

The dealer had the PCM flash updated before we bought it. The sticker says the update was BU7-FYF (or maybe 807-FYF?). Hard to tell from the handwriting.

The overhead showed 16.9 ave mpg when we got it, and it didn't change for the first two weeks we drove it around town.

I changed the oil and filter and both fuel filters after about two weeks. The fuel filters were filthy (wonder if they had ever been changed).

We took a long trip, and I reset the mileage calculator before we left. During about 1000 miles of highway driving it got about 18.5mpg!

Since we returned from the trip, we've been driving mostly around town and the mileage has been steadily decreasing (about 14.3mpg average now).

It has also been taking more time to start for the first start of the day, and it has started to belch a cloud of white smoke on that first startup.

I plan to clean the EGR valve first and then possibly take it to the dealer to check power balance.

I checked the oil this morning, and it may be 1/16 to 1/8 above the full line (hard to tell), but I can't smell any fuel on the dipstick.

My questions are:

Could the PCM reprogram have anything to do with the low mileage and difficulty starting cold?

Does this sound like an EGR issue?

Does this sound like an injector issue?

Thanks for your help,
Jay
428F250 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-07-2007, 08:18 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jul 2007
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Also, can anyone recommend a good dealer in the SF Bay area to do work on the PS Diesel?

Thanks,
Jay
428F250 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome