04 6.0 No Power and Rough Idle - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 09-27-2007, 03:24 PM Thread Starter
4X4
Powerstroke.org Rookie
 
Join Date: Sep 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04 6.0 No Power and Rough Idle

I have a 2004 6.0 and when I start it up after it has set for a few hours it idles rough and has no power. But once the engine temp. gets to the thermostat set temp. it idles fine and has all the power. Has anybody had this problem or know what the problem could be?

Thanks
4X4 is offline  
post #2 of 18 Old 09-27-2007, 03:27 PM
Compression Ignition Addict
 
kornfed's Avatar
 
Join Date: Aug 2007
Posts: 265
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not sure what it could be, mine only does that in the morining when it's been sitting all night. Keep checkin back though I'm sure someone will know.

2004 F350 Dually
Ex. Cab 4x4 Long Box
6speed 6.0L
Airaid filter and cold air
Zoodad
4in. Banks monster exhaust with no cat to 5in. tip
SCT x3
Autometer Z series gages and duall pillar pod
kornfed is offline  
post #3 of 18 Old 09-27-2007, 03:33 PM
Premium Member

 
DuraWhat?'s Avatar
 
Join Date: Apr 2007
Location: Jefferson GA
Posts: 649
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How often do you change your fuel filters? Any smoke? If so what color? Will it rev all the way up in drive/in park?
DuraWhat? is offline  
post #4 of 18 Old 09-27-2007, 03:39 PM Thread Starter
4X4
Powerstroke.org Rookie
 
Join Date: Sep 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Filters were changed last week, no smoke and it rev's up but rough. This problem just started monday.
4X4 is offline  
post #5 of 18 Old 09-27-2007, 03:55 PM Thread Starter
4X4
Powerstroke.org Rookie
 
Join Date: Sep 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Filters were changed last week, no smoke and it rev's up but rough. This problem just started monday.
4X4 is offline  
post #6 of 18 Old 09-27-2007, 05:32 PM
Member
 
Join Date: Aug 2007
Location: Independence, MO
Posts: 42
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem on my '03 Excursion. I changed fuel filters adn then this same problem started. I do not have a code reader to pull codes. I am interested in what you find out.

Thanks
Shawn

2003 Ford Excursion EB 4x4 6.0L PSD (First diesel ever). No mods yet. (Working on this).
sthompson134 is offline  
post #7 of 18 Old 09-27-2007, 07:51 PM
Powerstroke.org Rookie
 
Join Date: Sep 2007
Location: Shiner, TX
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It might possibly need a recalibration for the PCM. It depends whether or not there are any codes stored.
wwilson501 is offline  
post #8 of 18 Old 09-27-2007, 08:36 PM
Powerstroke.org Rookie
 
Join Date: Sep 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loss of Power

I had a similar problem on a 04' except it only lasted a few minutes. Mine turned out to be a corroded water separator on the fuel filter. You said that you changed the filters which means you most likely drained the water out of the separator, but you might want to pull it out completely to check for corrosion on the other side of the plate. There are only 4 screws holding it on so it only takes a few min. to do the job. Since this is an 04', is it under 100,000 miles? If so it is still under warranty and the fuel system is covered. Just a thought... At a minimum you could take it in for a diagnositic for the $100 deductable.
bluelights76 is offline  
post #9 of 18 Old 09-27-2007, 11:52 PM
Compression Ignition Addict
 
03-6.0PSD's Avatar
 
Join Date: Jan 2007
Location: Victoria BC Canada
Posts: 208
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to 03-6.0PSD
Here try this link, I just finished going through all that. Rough idles, white smoke, no power etc.

Picking up my truck!!!


Good luck and hope u have warrenty. other wise you might be doing injectors soon.

2006 F-150 5.4L Lariet Crewcab 5.5 box Black on Black fully loaded 4x4

No Longer: 2003 6.0 PSD F-350 EXT Cab, Longbox, 4X4, SRW
SCT Xcal3 From DJ's
AEM Brute Force Intake
MBRP 4'' Turbo Back w/ Muffler and Cat Delete
Dual Pod with Silver Faced Stewart Warner Gauges Boost and Pyro
High Idle Mod
8'' Lift
37'' Tires
20'' Mags
Chrome Handles and Mirrors
Billet Grill
03-6.0PSD is offline  
post #10 of 18 Old 09-28-2007, 03:59 AM Thread Starter
4X4
Powerstroke.org Rookie
 
Join Date: Sep 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the replies, I will look at these issues and see what I can find this weekend.
4X4 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome