Few Things to do. - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2007, 12:10 AM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Victoria BC Canada
Posts: 208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to 03-6.0PSD
Few Things to do.

Well I got my trucked reflashed today, the dealer had to spend an hour and a half to try and reflash it.

The bully dog trial had not removed itself, and apparently as I was talking to a private tech that does performance diesel stuff, he said they dont remove from the computer and sometimes can take hours to clear off.

How ever my truck is back to 100% stock. but I still cant buy my SCT yet

I went to harbour city diesel, the Private tech. and he took my truck for a test drive. when he came back he stated, " I cant believe how gutless your truck is." It shouldnt be that way.

He started the truck again, and revved it to around 1200 and said can u hear that. Its missing. and its missing bad. He also said thats why your truck idles rough and at 1200 RPM its shaking the truck.

He then asked me if I was having hard and long starts when cold. I said yes.

He asked if I had lots of white smoke, I said yes. He asked if when it was cold it wouldnt make enough power and was very sluggish to go up steep banks, I said yes.
or roads. (my driveway for one)

Then asked me if my warrenty was still good. I said yea i still got some left.

GET IT IN TO THE SHOP NOW! You need injectors, Forsure one has already gone, and they maybe be others on their way out.

It makes sense, since I have noticed my truck to be acting weird and getting rougher at starts.

I called the shop back and told them everything, they said it sounded like that was the problem and I needed to get it in asap.

I will be calling them back tomorrow to set it up.
I wish I was doing aftermarket injectors, but like he told me, Its going to cost alot to do it myself, and this will only cost me a deductable insted of 5000. or w/e.


Anyways another question.

my EGT gauge has been reading 1100 some times. is this normal? its stock other them intake and exhaust. and my boost has only gone as high as 24 to 26 PSI.

average high temp is around 1000. The probe is mounted on the drivers side Exhaust manifold. I exspected to see it high, but its climbs really fast and high for stock I think. and thats if Im punching it. just cruising is around 400- 900 depending on gear and speed. aswell as RPM.

If I do have a bad injector, could that be causing the high temps?

The mechanic I was talking to today is a certified CAT Factory tech, and has a well known name around here for knowing his stuff. he has carlots calling him for help all the time. and started his own shop in the diesel pick up world.

Thanks again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-25-2007, 12:12 AM
COLLEGE KID
 
Join Date: Feb 2007
Location: Chicago, IL
Posts: 3,226
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to lifewitlooie
Dont know man. bump for ya
Reply With Quote Quick reply to this message
  #3  
Old 09-25-2007, 12:14 AM
Banned
 

Join Date: Apr 2007
Location: Ponca City, Okla
Posts: 1,089
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to Blue01F250 Send a message via Yahoo to Blue01F250
Wow man - sounds like it was a good thing you talked to him -- why didn't the dealer notice that when you had it in there??

hope you get everything fixed up under warranty and are good to go -- I do not have a clue though about the EGT's.
Reply With Quote Quick reply to this message
  #4  
Old 09-25-2007, 12:15 AM
COLLEGE KID
 
Join Date: Feb 2007
Location: Chicago, IL
Posts: 3,226
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to lifewitlooie
Get to the stealership under warranty quick!
Reply With Quote Quick reply to this message
  #5  
Old 09-25-2007, 12:32 AM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Victoria BC Canada
Posts: 208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to 03-6.0PSD
This dealership is pretty good, but around here inless you tell them what you think and what you want, they wont go ahead and fix it. so I had thought thats how my truck was, never driving any other 6.0L other then mine.

Im hoping to take it to them wedensday
Reply With Quote Quick reply to this message
  #6  
Old 09-25-2007, 05:44 AM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 17,136
Thanks: 13
Thanked 48 Times in 37 Posts
Feedback Score: 4 reviews
You say reading 1100* some times. Mine was doing that in stock form, some times, but mostly when I was wide open throttle... If you weren't WOT, it definitely shouldn't be that high and average shouldn't be about 1000*... If you have the latest PCM flash, it wouldn't be computer related, so maybe you should look at injectors. Also, in stock form, you shouldn't have hardly any visible emission from your tail pipe...

FWIW, I have never seen it blow white smoke and have it be anything other than steam, but others have indicated that could be an overfueling condition as well... Have you noticed your engine coolant running hot (fan cycling on more than before)? How about coolant smell or heavy puking out your degas bottle? These would be indications of head gasket failure and/or EGR cooler failure.
Reply With Quote Quick reply to this message
  #7  
Old 09-25-2007, 11:41 AM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Victoria BC Canada
Posts: 208
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to 03-6.0PSD
its none of those, and yes 1100* is wide open. 1000* was not average but I had seen it while crusing in some rpm ranges.
Reply With Quote Quick reply to this message
  #8  
Old 12-03-2008, 08:42 PM
Emergency Services
 

Join Date: Jul 2008
Location: phoenix
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a problem kinda similar i need help with my 03 6.0 is blowing white smoke and in between 45 and 60mph it will shake like runnin out of fuel any ideas would be great! thanks in advance
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors