No power after 45-50 MPH after work done - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-27-2012, 01:23 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Glen Burnie, MD
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No power after 45-50 MPH after work done

Hey guys, im new to the Powerstroke world.

i just ha my Cat deleted and egr went out and had that deleted. now there is no power after 45-50 on the highway, unless i floor it for a few secs, then it will shoot up RPMs. also, since the Cat/Egr delete, it does not smoke... i used to be able to blow puffs at tailgaters lol


No trouble codes besides the EGR.... i changed the fuel filter, its due for an oil change soon, i just dont know what it could be.

i was thinking (but i know very little about these engines):
*Fuel pressure regulator (has silver spring that i know of, want to get the new blue spring anyways)
*Computers reflashed

Any help would be great!!!

i have on my truck:
*MBPR 4" cool dual turbo back exhaust W/ no cat
*Edge juice W/ attitude
*egr delete
*brute force intake
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-28-2012, 08:34 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Glen Burnie, MD
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edit:

So i was digging around in the enging bay last night, found a broken ground wire. gonna fix it and see it its any different.


Again, ANY help would be great!!
Reply With Quote Quick reply to this message
  #3  
Old 03-29-2012, 11:04 AM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Same problems

After I installed a delete kit and new oil cooler and FICM i have the same problems. I was thinking the replacing the pedal (TPS). But Im not a mechanic and will try any tips to fix this problem.
Reply With Quote Quick reply to this message
  #4  
Old 03-29-2012, 11:12 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Glen Burnie, MD
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by sparker4164 View Post
After I installed a delete kit and new oil cooler and FICM i have the same problems. I was thinking the replacing the pedal (TPS). But Im not a mechanic and will try any tips to fix this problem.
any codes? and you may want to look around the ficm and make sure the connectors are in all the way/ the harness isnt chaffed. i found a broken off ground wire coming out of the ficm harness.... i am new to diesel trucks and am in no way a mechanic lol but can handel simple things.

also, my truck will build boost, but stays around 2K rpm and does not "go"....

Last edited by Dmoney's F250; 03-29-2012 at 11:18 AM.
Reply With Quote Quick reply to this message
  #5  
Old 04-05-2012, 02:06 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Glen Burnie, MD
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Think i have it figured out.

Quote:
Originally Posted by Dmoney's F250 View Post
any codes? and you may want to look around the ficm and make sure the connectors are in all the way/ the harness isnt chaffed. i found a broken off ground wire coming out of the ficm harness.... i am new to diesel trucks and am in no way a mechanic lol but can handel simple things.

also, my truck will build boost, but stays around 2K rpm and does not "go"....
just took it to the shop, they hooked up a scanner. turns out my turbos bad Going to see how my tax refund looks and plan to put in a powermax... for $1400.... hope thats all the problems i have for a while.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
power loss egr flash

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:48 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors