No Acceleration - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-26-2012, 08:02 PM Thread Starter
Join Date: Apr 2009
Location: Memphis, TN
Posts: 44
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No Acceleration

I apologize, but I have searched until my eyes hurt and cannot find my problem.

Truck in question is a stock 2006. Two weeks ago she started accelerating "odd". I took it to Ford when the CEL came on and they diagnosed and replaced the ICP. Seemed to fix the problem. This evening on the way home, the tach suddenly dropped to 500 rpm and stayed there. A Yugo honked as it passed me! I limped to the side of the road. No matter what I did, she would not go past 500 (or so) rpm. Finally shut her down and restarted and everything is good again. No problems the rest of the drive home. I have not tried to pull any codes yet, but the neither the CEL nor any other light is on. Ideas?


2006 F250 Lariat Crew 4x2
All stock and liking it that way
tnscoutr is offline  
Sponsored Links
post #2 of 2 Old 03-27-2012, 09:54 AM
Compression Ignition Addict
Join Date: May 2010
Location: Warren, Oregon
Posts: 1,515
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Well to start with you need gauges like the Edge Insight CTS or ScanGaugeII harder to set up but both are plug and play because the gauges in the dash just take up space and look good. Sounds like it went limp to save itself you need the gauges to check ECT-EOT max spread is 15* i think if you are at 10* doing 60 after 2 or 3 minutes the oil cooler is getting plugged.
It could be something different need to see if you have any other codes and the gauges will read codes also.
2 stroker

06 F350 4x4 PSD Lariat FX4 CC LB
Edge Insight CTS Expandable Pyro
AutoMeter Fuel Pressure Gauge
Updated Fuel Reg. Kit 3C3Z-9T517-AG
Amsoil By-Pass(Amsoil 5w40)
Delo ELC Coolant
Coolant Filtration System
pulling a 14,000 lb Alpenlite 5er
97 F350 4x4 PSD CC LB
PacBrake&ATS converter lockup
3" dp 4" exhaust
TruCool 28,000 lb cooler
Tymar Intake
A piller EGT,Boost,Trans
2 stroker is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome