Bad PCM????? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-16-2012, 06:35 PM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Newellton, LA
Posts: 1,249
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Bad PCM?????

First off let me give a little history. About 2 months ago I blew HG's and got it studded, at that time I had the injectors flow tested and they said that they where not flowing enough on the high side and that they were almost gone. About a month ago I got Eric to tweak my Extreme Street tune. I uploaded the new tune and that is when this problem started. First I noticed that it had considerably less power. I uploaded the original Extreme street and still the same thing, a lot less power. I figured that my injectors had finally got bad enough for me to feel it. I got me a set of 155's from Jesse Warren and installed them. Got all of my tunes updated for them. Fuel psi was low after that, ordered an Airdog 2. Got it put on today, 62 psi fuel now at idle and WOT. Still no change in the lack of power. I return the truck back to stock and drove it down the road about 6 miles, it ran as good as they do on stock tuning. Got home killed it and now it will not start. I have 0.6v ICP while cranking, 62 fuel PSI, no codes. Also ever since this started I cannot get my EGT's over 1200 and that used to be really easy to do. Also I am draining batteries like crazy now, they were only 4 months old. I let my truck sit for 2 weeks while at work, come home they are dead as hell. I go get 2 more under warranty, 2 days later I let is sit for 3 days while waiting on Airdog to get here and again dead as hell. Sometimes when I turn the key on the WTS light will come on and the glow plugs will not, and the truck is plenty warm. Sometimes when I turn the key on the fuel pump will not come on. Sorry for being so long just trying to be thorough. Any and all help is greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-16-2012, 06:39 PM
Compression Ignition Addict
 

Join Date: Sep 2011
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What are your ficm volts? Sounds like a bad ficm or glow plug controller to me... Was it hot when you tried to re-start or was it cold?


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #3  
Old 03-16-2012, 06:42 PM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Newellton, LA
Posts: 1,249
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
FICM is a constant 48v. Yes is was hot when I tried to restart it.
Reply With Quote Quick reply to this message
  #4  
Old 03-16-2012, 07:01 PM
Compression Ignition Addict
 

Join Date: Sep 2011
Posts: 152
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well if it was hot then it's not the glow plugs and it's not the ficm voltage... Possible it's still a bad ficm though... Are there any codes?


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #5  
Old 03-16-2012, 07:09 PM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Newellton, LA
Posts: 1,249
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Nope no codes what so ever.

Sent from my DROID RAZR using AutoGuide.com App
Reply With Quote Quick reply to this message
  #6  
Old 03-17-2012, 08:44 AM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Newellton, LA
Posts: 1,249
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Update - last night I walked out to the truck and my Insight was turning on and off, repeatedly. I had the key in my pocket. Walk out there this morning, truck starts instantly and runs fine. Still missing that lost power though.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors