2003 Excursion rough idle then stall... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-07-2012, 03:22 PM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 2003 Excursion rough idle then stall...

I was driving down the express way the other day when all of a sudden out of nowherethe engine started losing power. It was not a quick loss of power but is very slow over 20 seconds loss of power until the engine eventually stalled. it would not restart. I had to have it towed back to my house. When I tried to start is the next day it started right up. it idled very rough like it was missing on at least 1 or 2 cylinders until eventually after about a minute or 2 it stalled and would not restart just like the day before. this process repeats itself. I can start it once then after it stalls the first time it will not restart no matter what I try unless it sits for a period Of at least 6 hours.

now I'm no diesel expert but to me this sounds like a fuel problem. My thoughts are either fuel filters they have about 20,000 miles on them, I was going to change them on the next oil change (about 600 miles from now). or I heard that the FICMs on the 6.0s are prone to go.

It is a 2003 ford excursion, all stock, with 205,000 miles. any help would be appreciated. If you have had an issue similar to mine or you have an idea as to what could be causing the issue I would greatly appreciate to hear about it.

Last edited by Xx_Razgriz_xX; 03-07-2012 at 03:44 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-27-2012, 07:49 AM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
didnt anyone get back to you , what was problem , mine did same thing yesterday

didnt anyone get back to you , what was problem , mine did same thing yesterday

Quote:
Originally Posted by Xx_Razgriz_xX View Post
I was driving down the express way the other day when all of a sudden out of nowherethe engine started losing power. It was not a quick loss of power but is very slow over 20 seconds loss of power until the engine eventually stalled. it would not restart. I had to have it towed back to my house. When I tried to start is the next day it started right up. it idled very rough like it was missing on at least 1 or 2 cylinders until eventually after about a minute or 2 it stalled and would not restart just like the day before. this process repeats itself. I can start it once then after it stalls the first time it will not restart no matter what I try unless it sits for a period Of at least 6 hours.

now I'm no diesel expert but to me this sounds like a fuel problem. My thoughts are either fuel filters they have about 20,000 miles on them, I was going to change them on the next oil change (about 600 miles from now). or I heard that the FICMs on the 6.0s are prone to go.

It is a 2003 ford excursion, all stock, with 205,000 miles. any help would be appreciated. If you have had an issue similar to mine or you have an idea as to what could be causing the issue I would greatly appreciate to hear about it.
Reply With Quote Quick reply to this message
  #3  
Old 04-27-2012, 08:11 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,469
Thanks: 0
Thanked 18 Times in 18 Posts
Feedback Score: 0 reviews
Both of you need to look up at the header of this page, right next to the pickup are some links. Click on the 6.0L Poblems Forum link the first post is a sticky with an exellent write up of of the different causes and tests for no start/hard start conditions.
Reply With Quote Quick reply to this message
  #4  
Old 04-27-2012, 08:30 AM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya. Put a snap on computer on it and the hpop was only making 2-300psi. Changed that and shes running great now.
Reply With Quote Quick reply to this message
  #5  
Old 04-27-2012, 11:08 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,469
Thanks: 0
Thanked 18 Times in 18 Posts
Feedback Score: 0 reviews
Glad ya got her fixed.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
diesel, excursion, idle, rough, stall

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors