2004 6.0 ex missing or chugging Help! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-06-2012, 09:28 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Apr 2010
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2004 6.0 ex missing or chugging Help!

We have a 2004 6.0 Excursion that recently started running really bad.
the vehicle sits for extended peiods of time due to my parents working over seas. The ficm voltage is good ( first place I looked ) Temperatures are within reasonable range. Was thinking maybe a egr cooler but no signs or symptoms of that. Need to get this thing back up and running this week so any help would be greatly appreciated.

2000 F250 7.3 "Ol' Faithful"
2004 Ex 6.0 "Tha Turd"
2004 F 250 "Beast"
jhenson is offline  
post #2 of 4 Old 03-06-2012, 04:24 PM
Powerstroke Techie

 
Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,825
Thanks: 33
Thanked 143 Times in 129 Posts
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
Garage
Feedback Score: 4 reviews
idling bad or running bad driving down the road?

you may want to try pulling the EGR valve to see if it's stuck open.

-Matt

Ford Senior Master Tech

2015 F-250 XLT 6.7L

2006 F-250 6.0L SOLD
sinner6.0L is offline  
post #3 of 4 Old 03-06-2012, 05:24 PM
Member
 
00Javelin's Avatar
 
Join Date: Apr 2009
Location: Northport, AL
Posts: 86
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like egr valve trouble I had...cleaned the egr valve and she ran like a champ. Just my .02. Most folks on here know waaaay more than me though!


2005 F250 4X4 Lariat
6.0 Stroker
Mods To Come
00Javelin is offline  
post #4 of 4 Old 03-07-2012, 07:46 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Apr 2010
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well after getting down here and running it I pulled codes off the edge cs.
p0401
p0603
p132b

Truck seems to be running ok today but temps are 20d out and the turbo has started farting. any tips or ideas. I have the stuff ordered for egr delete and oil cooler replacement.

Thanks

2000 F250 7.3 "Ol' Faithful"
2004 Ex 6.0 "Tha Turd"
2004 F 250 "Beast"
jhenson is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome