Acceleration Quirk - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-05-2012, 05:00 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2012
Location: Gainesville, FL
Posts: 1,203
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Skype™ to bwmtnbiker
Acceleration Quirk

There are times when Im idling or coasting that when i gently press back on the accelerator it gives it a lot more fuel than it should then backs down. Its acting like I am pushing the throttle half way and then backing off immediately. I noticed it mostly after I did the blue spring mod but if i remember right it did it before just not as bad. Could this be an issue with the throttle positioning sensor or something like that?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-Brian

2003 F-250 6.0L - Lariat King Ranch
-300k+ miles and still strong
Current Mods
-6.5" Pro-Comp lift
-Edge CTS
-SCT X3 (Tuned by Vivian
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
-4" Turbo Back Silverline Exhaust, 5"tip
-Blue Spring Mod
-Sinister Coolant Filter
-Oil Cooler
-Sinister EGR Delete
-OEM Cab Lights
Wants/Soon
-ARP Studs
-MTW Stage 1 or Hybrid
-6.4 Banjo Bolts?
bwmtnbiker is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-05-2012, 05:26 AM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 66 Times in 62 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Probably or the sender on the acclerator pedal itself. The 03 uses a single reostat pedal sensor.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #3 of 4 Old 03-05-2012, 05:41 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2012
Location: Gainesville, FL
Posts: 1,203
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Skype™ to bwmtnbiker
Quote:
Originally Posted by dannyboy950 View Post
Probably or the sender on the acclerator pedal itself. The 03 uses a single reostat pedal sensor.
I have a feeling thats what is causing it. I just remembered that the edge i have will check the throttle percentage so when I leave work tonight ill check it. Maybe I can pull the sensor out and clean it...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-Brian

2003 F-250 6.0L - Lariat King Ranch
-300k+ miles and still strong
Current Mods
-6.5" Pro-Comp lift
-Edge CTS
-SCT X3 (Tuned by Vivian
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
-4" Turbo Back Silverline Exhaust, 5"tip
-Blue Spring Mod
-Sinister Coolant Filter
-Oil Cooler
-Sinister EGR Delete
-OEM Cab Lights
Wants/Soon
-ARP Studs
-MTW Stage 1 or Hybrid
-6.4 Banjo Bolts?
bwmtnbiker is offline  
post #4 of 4 Old 03-06-2012, 12:24 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2012
Location: Gainesville, FL
Posts: 1,203
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Skype™ to bwmtnbiker
Any other ideas? Priced out a new accelerator pedal and holy crap... They want almost $600 because I have the adjustable pedals.
I set my edge to monitor the throttle percent and it seemed to be fine. It almost seems like the pedal is reading one thing and its doing something different. Sometimes it sounds like I'm feathering the pedal even though I'm holding it steady.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

-Brian

2003 F-250 6.0L - Lariat King Ranch
-300k+ miles and still strong
Current Mods
-6.5" Pro-Comp lift
-Edge CTS
-SCT X3 (Tuned by Vivian
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
-4" Turbo Back Silverline Exhaust, 5"tip
-Blue Spring Mod
-Sinister Coolant Filter
-Oil Cooler
-Sinister EGR Delete
-OEM Cab Lights
Wants/Soon
-ARP Studs
-MTW Stage 1 or Hybrid
-6.4 Banjo Bolts?
bwmtnbiker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome