2006, Flashing Tow/Haul light and Tach is barely working. - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 02-28-2012, 05:44 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2006, Flashing Tow/Haul light and Tach is barely working.

I have a 2006 6.0 liter that the tow/haul light is flashing. My Tach just started barely working, it is moving but won't go above 1000 rpms at all (my scan gauge is showing normal rpms). I also have an ABS and an Airbag light, not sure if these are all because of the same issue or not? The only CEL I am getting is 403 and 405 (EGR Delete). Once in a while I get a PO720 as well.

Does anyone have any ideas?
Power_Stroke_11 is offline  
post #2 of 7 Old 02-28-2012, 05:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Also it will not shift into overdrive.
Power_Stroke_11 is offline  
post #3 of 7 Old 02-29-2012, 04:00 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I think the previous owner put a tuner on this truck, is it possible that these issues could be caused by that and I just need to get the ecm reflashed.
Power_Stroke_11 is offline  
post #4 of 7 Old 02-29-2012, 04:16 AM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
With all those different issues, it's hard to tell. Maybe loose battery connections, or something more complicated.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #5 of 7 Old 03-01-2012, 12:42 AM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 62 Times in 58 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
A flashing tow/haul light indicates a tranny problem. {no overdrive }
As for the others could be a bad cluster module.
As the man said with all that going on kinda hard to tell.


Lord I shall lead them to the water but I will not try to make them drink
dannyboy950 is offline  
post #6 of 7 Old 03-01-2012, 07:39 PM
Premium Member
 
southend's Avatar
 
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
alternator, ground cable, positive cable, batteries...........
southend is offline  
post #7 of 7 Old 03-04-2012, 09:54 AM
GDT
Powerstroke.org Rookie
 
Join Date: Nov 2007
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Alternator caused a ton of electrical problems for me. Check that, I chased other things when that was the real issue.
GDT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome