vgt problems??? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-22-2012, 08:57 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2012
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
vgt problems???

I got my truck back from the shop and it had a hissing noise from the turbo area. I checked all the hoses they were ok. Still had a hissing noise, I unplugged the vgt and it stopped. Does anybody have an idea of what could be wrong with it??
diesel rookie is offline  
post #2 of 4 Old 02-22-2012, 10:58 AM
Compression Ignition Addict
 
DoubleDpsd's Avatar
 
Join Date: Mar 2007
Posts: 4,579
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Quote:
Originally Posted by diesel rookie View Post
I got my truck back from the shop and it had a hissing noise from the turbo area. I checked all the hoses they were ok. Still had a hissing noise, I unplugged the vgt and it stopped. Does anybody have an idea of what could be wrong with it??
Y pipe or downpipe isn't sealed right. Probably y pipe. Does it sound like this.


2003 centennial edition f250 4x4 ccsb auto w/blackwater long block w/arp's, 4" exhaust, airaid intake, ODawg's manifold, itp's reg return, sap modified solenoid, DC power 185amp alt, motorcraft 850cca, Warn Hubs, RS 55w 6k hid's, harley headlights, bpd 58v 6 phase, bpd water pump, dieselsite coolant filter, elc coolant, php gryphon, Xcal2 w/unlimited tow, new hfcm, glowshift fuel psi gauge, icon level kit, 20" kmc hoss, 305/55 terra grapplers TOTALED
DoubleDpsd is offline  
post #3 of 4 Old 02-22-2012, 11:04 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2012
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thats exactly what it sounds like thanks
diesel rookie is offline  
post #4 of 4 Old 02-22-2012, 11:06 AM
Premium Member
 
Join Date: Oct 2010
Posts: 2,098
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 28 Times in 26 Posts
Feedback Score: 0 reviews
Yep sounds like you have an exhaust leak, need to get the ypipe lined up correctly. Very common after turbo removal.

05 Extended Cab FX4
SCT w/ Gearhead Tunes
Ble-Blah mod...
Edge Insight CTS w/EGT
PHP Tuned FICM-Hercules
a2elvis is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome