Sudden loss of power - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-07-2012, 03:09 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
Sudden loss of power

2003 6.0 all of the sudden i have lost power going up grades and passing power, Inter cooler boots seem ok, truck shifts ok and runs 65 down the road no problem, No check engine light but when i hook up scanner i have DTC p2290, will this put the truck into a limpmode condition

Last edited by roche837; 01-12-2012 at 12:20 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-07-2012, 05:04 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
well.... i guess ill clear the dtc and try it UPDATE: DTC p2290 returned

Last edited by roche837; 01-12-2012 at 12:20 AM.
Reply With Quote Quick reply to this message
  #3  
Old 01-07-2012, 06:01 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
anyone had any similar issues?
Reply With Quote Quick reply to this message
  #4  
Old 01-07-2012, 07:15 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
So after clearing the dtc's the truck still hesitates under full acceleration, any help would be appreciated, the truck doesnt miss or smoke just doesnt seem to not kick down when you lay into it, turbo seems to spool ok, at a loss.

UPDATE: Just removed and cleaned EGR valve, it was pretty clogged up, I hope it was the problem i will update later. (NOT THE PROBLEM)

Last edited by roche837; 01-12-2012 at 12:21 AM.
Reply With Quote Quick reply to this message
  #5  
Old 01-07-2012, 11:50 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
Seemed to be a little bit better with a cleaned EGR valve, (Only drove it briefly but overall no change)

Trying it completely disconnected on the trip home. Update results later.


I feel like im talking to myself!

Last edited by roche837; 01-08-2012 at 12:47 PM.
Reply With Quote Quick reply to this message
  #6  
Old 01-08-2012, 12:46 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
UPDATE: Cleaned EGR with no change, Then half way home i Unplugged it with no change.

Will have FICM Tested.

Last edited by roche837; 01-12-2012 at 12:23 AM.
Reply With Quote Quick reply to this message
  #7  
Old 01-09-2012, 04:56 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Central NY
Posts: 1,821
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Test that FICM yourself. I can repair it if need be. I'm not sure that's your issue.

Are you getting any smoke out the exhaust when this is happening? Truck making any funny noises, or just starts losing power? Only on hills?
Reply With Quote Quick reply to this message
  #8  
Old 01-09-2012, 03:15 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
Quote:
Originally Posted by mdub707 View Post
Test that FICM yourself. I can repair it if need be. I'm not sure that's your issue.

Are you getting any smoke out the exhaust when this is happening? Truck making any funny noises, or just starts losing power? Only on hills?
FICM was rebuilt last winter, no smoke at all, turbo fart under hard acceleration, engine does not stumble, miss, skip, just has no power when you lay into it.

Im suspecting a leaking turbo boot. I know its not the EGR because i cleaned and unplugged it with no change, I know its not the VGT stuck because with my SP exhaust i can hear it being cycled by the PCM.


This leaves a boost leak or something with an injector?, I just ordered some VPMAX inter-cooler boots. mine look pretty ragged but Ive been working all this weekend and haven't had time to pull them off yet. (DO NOT BUY VP MAX BOOTS HAD NOTHING BUT PROBLEMS WITH THEM!!!!)

Last edited by roche837; 05-11-2013 at 09:40 PM.
Reply With Quote Quick reply to this message
  #9  
Old 01-09-2012, 05:41 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: Central NY
Posts: 1,821
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
If it was from a lack of air flow you'd know it, it wouldn't be farting non stop. Have you checked or cleaned your EPB sensor at all? I'd remove the tube and sensor and clean both. Inspect the wiring going to that sensor as well. It is on the drivers side exhaust manifold.
Reply With Quote Quick reply to this message
  #10  
Old 01-09-2012, 05:48 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Western NY (Twin Tiers)
Posts: 1,127
Thanks: 3
Thanked 15 Times in 5 Posts
Feedback Score: 4 reviews
It doesnt fart until i mash the pedal and release quickly(which is normal from my experience), i have not checked the EPB sensor i will seeing how i have to remove the intake and what not to do the intercooler boots, Just read a write up on the procedure.

Thanks for the insight though your the only person who has suggested anything. Leave it to a fellow ESS.

Last edited by roche837; 01-12-2012 at 12:24 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:12 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors