6.0 studdering in over drive?? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-24-2011, 06:23 AM Thread Starter
Compression Ignition Addict
kTm520's Avatar
Join Date: Jan 2010
Location: nj
Posts: 454
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 studdering in over drive??

My turbo studders in over drive when i get into it and the truck doesnt want to go, sometimes shifts down because of it. No smoke or anything but i can hear my powermax making a little noise as if its studdering. Its fine at wot other than in overdrive. Im running innovative xrace, cant remeber if vivians tunes did this. Any of you guys expirenced this?

2005 King Ranch, arps, oem gaskets, pmax, 190's/100's bu warren, egr delete, 5 inch exhaust, sct tuned by quick tricks/innovative/gearhead, suncoast trans, custom paint work work
kTm520 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome