help! exxtremely high egts - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-30-2007, 08:33 AM
Member
 

Join Date: Jun 2007
Location: Northridge, CA
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
help! exxtremely high egts

hello all, when i was driving home from my buddies house last night i noticed my egt's at around 1350, i let the engine cool off and started it about 10 minutes ago and at idle i noticed my egt's at 650! what on earth is going on here?! I dont know of these problems are related but my battery light intermittently turns on and off (i just replaced my batteries) and i just installed my 4" turbo back straight pipe about 5 days ago.. but no issues until today. Anybody know why my egt's would be so high?

thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-30-2007, 08:39 AM
Serving Our Country!
 

Join Date: Jul 2007
Location: Tucson
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to AMMO22
Is the truck missing or running wierd in any other way? I asked this because I have high EGT's right now because of bad injectors. If the the bad injectors are dumping fuel it will get hot hot during normal driving. If its not that, its possible something in the EGR system if acting up.
Reply With Quote Quick reply to this message
  #3  
Old 08-30-2007, 08:42 AM
Member
 

Join Date: Jun 2007
Location: Northridge, CA
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The truck seems to be running completely normal other than that, infact 1 minute ago i started it up again and the idle egt's are around 300! why would 10 minutes ago they be extremely high and now they be fine? When i had my tranny serviced the tech said i had an injector issue, however my truck seems to be running just fine. no check engine light or problem lights (besides that intermittent battery light) Any ideas?
Reply With Quote Quick reply to this message
  #4  
Old 08-30-2007, 08:44 AM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,662
Thanks: 3
Thanked 13 Times in 12 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Sounds like an injector issue to me, but I'm sure a tech will be along shortly to help out....
Reply With Quote Quick reply to this message
  #5  
Old 08-30-2007, 08:54 AM
Member
 

Join Date: Jun 2007
Location: Northridge, CA
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for the responses julian and brett! i'm going to take it on a short drive and see what happens
Reply With Quote Quick reply to this message
  #6  
Old 08-30-2007, 09:03 AM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Possible the gauge is giving you faulty readings?
Reply With Quote Quick reply to this message
  #7  
Old 08-30-2007, 09:06 AM
Compression Ignition Addict
 

Join Date: Aug 2006
Posts: 280
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Regen?
just kidding, I dont know.
Reply With Quote Quick reply to this message
  #8  
Old 08-30-2007, 09:29 AM
Member
 

Join Date: Jun 2007
Location: Northridge, CA
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just went on a short drive, EGTs seem to be fine averaging around 650. it was too dark last night for me to see if black smoke was coming out of my exhaust, but it is a possibility that my egt probe is faulty, has anybody heard of this happening?
Reply With Quote Quick reply to this message
  #9  
Old 08-30-2007, 09:32 AM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Sure its probobly not somthing that happens alot, but thats a good reason to antisieze the probe in case it does go bad you can get it out.
Reply With Quote Quick reply to this message
  #10  
Old 08-30-2007, 09:57 AM
Member
 

Join Date: Jun 2007
Location: Northridge, CA
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sorry for the newbie question, what is antisieze-ing the probe? i do have another one laying around i'll swap them out in a few hours when it cools down
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:49 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors