Please help me, I'm an idiot - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-18-2011, 09:28 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Shilo, Manitoba
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Please help me, I'm an idiot

Hey all, I'm new to this forum, but I've been watching and reading for about two months now. I have a 2004 PSD F350. Last night, I got the bright idea to clean the egr valve after changing my oil and fuel filters. So I followed all the steps that I have seen on youtube and read here. After putting it back in, it started up, then shut down. Then I restarted it, and it idled hard for a second then ran just fine. The only problem is when I rev it or drive it. If I press the pedal, it sputters for a second with a lot of smoke and no power, then it picks up and goes like it always has. I tried unplugging the egr valve but no change. Any ideas would be great, thank a lot!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-18-2011, 09:57 AM
Chapter Director
 

Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'd check to see of the gasket or either of the orings got messed up
Reply With Quote Quick reply to this message
  #3  
Old 09-18-2011, 01:46 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: wichita ks
Posts: 971
Thanks: 0
Thanked 4 Times in 3 Posts
Feedback Score: 0 reviews
You did a lot of work at once and this problem could be related to anything you did.

Check the o-rings on the EGR valve.

Did you use OEM filters and do they have OEM caps on them. YES, this is a big deal on a 6.0

You may have air in the fuel system, the fuel filter cap may be cross threaded or just loose enough that it is sucking air in. I have seen this at the filter under the truck sometimes.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
6.0, egr, no power, smoke, valve

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:41 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors