surge!!!!!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-10-2011, 10:29 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
surge!!!!!!

I have a 2004 king ranch also just put it in the shop this pass week for the same problem.Tthey put the truck on a scanner and said 1 and 7 injectors was bad so i replaced them. Picked the truck up and it still doing it. when i get to about 2000 rpm and pulling my boat it will surge. i hope someone out there that knows what they are talking about can point us in the right direction.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-11-2011, 02:53 AM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 145
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
See that's a big problem for me. Who pays for those injectors? I have a surge problem too and can't get it figured out so I'm going to have to bring it to the dealer. But I don't want them throwing parts and my money at it until it's solved.
Reply With Quote Quick reply to this message
  #3  
Old 09-11-2011, 04:24 AM
Compression Ignition Addict
 

Join Date: May 2010
Location: Springport MI
Posts: 226
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I had a mis at different rpms, but never really was a huge issues so I let it go thinking it might be the tune I was running. I was going down the road one day and the ICP starting leaking oil badly. I replaced ICP and all the surging and mis I had before is all gone, runs nice and smooth, not saying that is your issue but might be something to look into. The ICP was $150 bucks at the local Ford garage and I put it in myself. Good luck

Eric
Reply With Quote Quick reply to this message
  #4  
Old 09-12-2011, 02:29 PM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well went and spent 6 hours at the shop today to nail down the surge problem. Tried changing map sensor, icp sensor ect.. Never stopped untill they then pulled the turbo and cleaned it, but it was not even that dirty. I Will post if it strats again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors