Towing Problem....Help - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-22-2011, 10:34 PM Thread Starter Rookie
Join Date: Aug 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry Towing Problem....Help

I recently purchased a 2005 6.0 It has an air intake and a catback exaust. Now I tried to pull a small bumper pull trailer, less than 5k pounds..i was able to reach 65 mph at first then it dropped down to 50 mph and i could not go any faster than that. When i tried to accelerate the turbo would not spool at all but the rpm would go up to 3000 and the truck just made noise but no additional power was given to the wheels. I pulled over and let it idle for about 10 min and the truck took off fine for the first mile or two and then did the same thing again. The truck never overheated and never threw a check engine light.

Could it be the turbo? maybe the cooler for the turbo isnt working? also if i am at a stop and i floor it, the truck takes off slower than if i were to give it half throttle?
Shiner_man is offline  
Sponsored Links
post #2 of 3 Old 08-23-2011, 07:00 AM
Join Date: Dec 2007
Location: San Diego CA
Posts: 68
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
How does the truck run when you are not towing? Are the boost numbers rising when you step on it? You said you just purchased it, do you know the maintenance history on the truck. Oil changes. fuel filters etc. Have you inspected all of the boots for the turbo piping for cracks and leaks?
jeephauler is offline  
post #3 of 3 Old 08-23-2011, 05:44 PM
Long Member
TMAG6.0's Avatar
Join Date: Jun 2009
Location: SE Houston
Posts: 404
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
when i pull my RV 8~9k easy... at 65 mph she complains but doesn't auto limit. 60 seems to be the sweet spot. This sounds like some kind of tech prob, computer thing. there are better guys on here than me to answer this one. good luck. please let us know what fixed it.

2014 6.7 CCSB FX4
Edge CTS
6" RCX Lift
H&S Turbo Kit
DieselSite Filters
S&B Intake - Dry
No Limit EGR Delete
4" Flo-Pro / Donaldson
H&S Tunes via XRT Pro
Bilstein 5160s Front 5125s Rear
60gal RDS Auxiliary Fuel Tank/Toolbox

Click HERE to save a childs life.

TMAG6.0 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome