Fuse #33 Keeps Blowing - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-13-2011, 04:35 PM Thread Starter
Serving Our Country!
 
Guy_K's Avatar
 
Join Date: Aug 2011
Location: Las Vegas
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuse #33 Keeps Blowing

Hello,
New member and a new Ford owner. I just bought a 2005 F250 6.0l with 41k on it. It is in pretty good shape but has a few bugs. When I bought the truck from a private party they "forgot" to mention that the wipers didn't work. Since it hardly rains in Vegas I forgot to check before I bought it.

Anyways.. Fuse #33 (Cluster, 4x4, Wipers) blows the second I turn the ignition to run. I think its an instrument problem but to be honest I don't know where to start isolating the problem.

Also, I am having that relay issue where it take 30-60 second for the radio and wipers to come on. Could this have any affect on Fuse# 33? I wouldn't think so but you never know. Also, I have swapped relays and still have the 30-60 sec delay / fuse 33 blowing.

I looked for wiring diagrams and have not found any details with the instrument cluster/4x4/wipers.

Any help would be greatly appreciated.

Guy
Guy_K is offline  
post #2 of 2 Old 08-14-2011, 10:42 AM Thread Starter
Serving Our Country!
 
Guy_K's Avatar
 
Join Date: Aug 2011
Location: Las Vegas
Posts: 72
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Alright, here is an update. Disconnected the wiper motor.... fuse blew, disconnected the blinker arm/wiper control.....fuse blew, removed dash and disconnected instrument cluster..... fuse did NOT blow. So I have narrowed it down to the cluster. Any ideas on how to troubleshoot the cluster?

Thanks,
Guy
Guy_K is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome