well! 07 f250 6.0L 1st tow truck ride!!!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-31-2011, 09:06 PM
Serving Our Country!
 

Join Date: May 2009
Location: san diego
Posts: 369
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to navyeoseabee
well! 07 f250 6.0L 1st tow truck ride!!!!

not a fun one.

went from last weekend towing a 4 horse trailer for the first time like a champ to not wanting to start!

no smoke, no noise, but cranks and cranks and nothing, it is just like all 8 injectors are on a sit down strike!!


WTF!

-92,600ish miles
-no issues yet ever!
-no chip or programer
-only a airaid air filter done to engine
-about due on a oil change (5k since last one)
-can hear glow plugs relay
-sounds like fuel pump is coming on with the glow plugs
-FUEL is in the (2ND'ary)top filter housing
-still no unburnt fuel smoke out the tail pipe.



AT LEAST IT WAS TOWED by a ford...but it had 3 engines and only 118k miles on it....


last weekend:


this weekend!!!



Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-01-2011, 02:09 AM
Member
 

Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Don't know what is wrong with truck but this is not a good thing to see first thing monday morning . Sorry about your bad luck.
Reply With Quote Quick reply to this message
  #3  
Old 08-01-2011, 02:09 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,154
Thanks: 17
Thanked 66 Times in 60 Posts
Feedback Score: 3 reviews
STC. I almost guarantee it

the other chance is a ficm but usually that's a slower failure
Reply With Quote Quick reply to this message
  #4  
Old 08-02-2011, 07:32 PM
Serving Our Country!
 

Join Date: May 2009
Location: san diego
Posts: 369
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to navyeoseabee
Quote:
Originally Posted by sinner6.0L View Post
STC. I almost guarantee it

the other chance is a ficm but usually that's a slower failure
i just checked my messages after night school class and the ford service tech told me it is the STC, you were right on the money sinner!

but can you explain it? i didn't get to talk to him. BUT it is under warrentee so that is awesome! thanks guys for listening to my venting.
Reply With Quote Quick reply to this message
  #5  
Old 08-03-2011, 04:28 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Posts: 1,070
Thanks: 0
Thanked 17 Times in 17 Posts
Feedback Score: 0 reviews
on a lighter note truck is getting it from the rear in front of "nice an easy" its been a while but i hated when mine left me on the side of the road, it only did that once. in my case they never found a reason why even though it did it 6x in 3 years
Reply With Quote Quick reply to this message
  #6  
Old 08-03-2011, 04:59 AM
Unapologetically American


 

Join Date: Oct 2006
Location: Littleton, Colorado
Posts: 19,762
Thanks: 2
Thanked 9 Times in 8 Posts
Feedback Score: 4 reviews
Quote:
Originally Posted by navyeoseabee View Post
i just checked my messages after night school class and the ford service tech told me it is the STC, you were right on the money sinner!

but can you explain it? i didn't get to talk to him. BUT it is under warrentee so that is awesome! thanks guys for listening to my venting.
STC fitting is part of the HPO system. If it's leaking (or the dummy plugs) the HPOP will not provide sufficient pressure to operate the injectors. Glad you're back on the road
Reply With Quote Quick reply to this message
  #7  
Old 08-03-2011, 07:29 AM
Serving Our Country!
 

Join Date: May 2009
Location: san diego
Posts: 369
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to navyeoseabee
thank you guys for all the help,hope to be on the road by friday.
Reply With Quote Quick reply to this message
  #8  
Old 08-05-2011, 04:30 PM
Compression Ignition Addict
 

Join Date: May 2011
Location: Roseville/Greenwood
Posts: 404
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Common issue, myself and a co-work have had the same thing on our 05 and 06. Was covered under warranty too.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:32 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors