I really need some help guys please - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-19-2011, 04:52 PM
Member
 

Join Date: Dec 2010
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I really need some help guys please

Okay ive been on here lots trying tofind an answer. I have a 2003 f350 6 liter and i just had the head gaskets and apr studs done egr delete 4 inch exhaust and a few other little things. here is my issue when the truck warms up i loose power and it wants to die. if i shut the truck off when its warm it wont start until it cools off ( roughly about 1 or 2 hrs) i know everyone is saying high pressure oil leak. i took it to ford and they cant find the issue and it cost me 1400 already. if i go ahead and change the hpop and the stand pipes, ipr valve and icp sensor what is left to the hpop system. is this the whole system or am i missing something. Ford informed me there where no dummie plugs on this engin e so what am i missing????? and i also had the ficm tested and they said it reads good

Last edited by bedrockbobcat; 07-19-2011 at 05:06 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-19-2011, 04:57 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Boca Raton, Florida
Posts: 1,537
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 4 reviews
First, try having the PCM reflashed with the latest software. The computer in the 6.0 is a real ***** and a clean memory may be all you need so the truck can relearn with the new parts.
Reply With Quote Quick reply to this message
  #3  
Old 07-19-2011, 05:05 PM
Member
 

Join Date: Dec 2010
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
it ran fine for about 1000km and then started to act up
Reply With Quote Quick reply to this message
  #4  
Old 07-19-2011, 05:17 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Boca Raton, Florida
Posts: 1,537
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 4 reviews
First I would check with a scanner,Check for codes and Monitor the actual PID with the laptop or scanner to see if it is indeed the gauge or sensor,which it doesnt sound like.If the low pressure gearotor pump has problems the tk isnt goint to run,Well not long anyways when the High pressure pump is starved of Oil supply it will quit.This could be a combination of problems here Including a High pressure Oil leak.I would start off having it checked with a Laptop or compatible scanner.Is the Oil level full to begin with?.It is going to take some diagnosing to pin it down properly.There is a test port down on the Oil cooler housing to test base engine oil pressure,But it is a bear to get at.
Reply With Quote Quick reply to this message
  #5  
Old 07-21-2011, 05:52 PM
Member
 

Join Date: Dec 2010
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone.what else do i need to make this whole high pressure oil system new
Reply With Quote Quick reply to this message
  #6  
Old 07-21-2011, 07:54 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: wichita ks
Posts: 971
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
You need some type of engine monitoring solution in the first place anyway or else this is going to get super expensive super fast. I would suggest a Scangauge2 from Bullet Proof Diesel. Then you can monitor ICP vs IPR and scan for codes and learn a lot about your truck. Mine was $190 shipped. If you have a high IPR demand and a low ICP then you might consider that there is a high-pressure oil leak. Without data you are only guessing and shot gunning parts. I would think the HPOP is OK so you are looking at stand pipes. $150 in parts, Worst case is injector O rings are bad, but I believe this is a rare failure. I would bet this is a simple failure that will have it's roots in a torn O-ring...

CHECK OUT THE LINKS

DTS Articles - 6.0L ICP System Leaks

DTS Articles - New High Pressure Oil Connector

Last edited by HAM_RADIO_MAN; 07-21-2011 at 07:57 PM.
Reply With Quote Quick reply to this message
  #7  
Old 07-21-2011, 09:38 PM
Member
 

Join Date: Dec 2010
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
okay i bought stand pipes, icp sensor ipr valve hpop. what else am i missing???
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:54 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors