power stroke diesel problems - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 59 Old 08-09-2007, 06:48 PM Thread Starter
Member
 
Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
power stroke diesel problems

i have an 03 ford f 250 6.0 power stroke diesel and it will not accelerate over 1000 rpm and if you try to drive it it has no power it whistle really loud so i thaught the turbo be good and it smokes bad wht blue and i replace all the filters and replace the TP sensor and it is getting fuel dont know how much it starts fine runs fine and no check engine light and no codes could it be the turbo you can hold the accelerator to the floor and it will not go over 1000 rpm i have checked the tubes and every thing does any one have an idea what it could be
tj1974 is offline  
Sponsored Links
Advertisement
 
post #2 of 59 Old 08-09-2007, 08:05 PM
Compression Ignition Addict
 
Tacomarunner's Avatar
 
Join Date: Sep 2006
Location: So Cal
Posts: 268
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Punctuation maybe?

Russell

O7 F-5504dr 4wd cab and chasis w/ 12' Scelzi service body 6spd manual trans. 200" WB 17,950 GWWR 4.88 gears
Overhead gauges w/ EGT and Boost. FCDP EGR Delete. AEM Workhorse CAI. Down pipe only, no cat or muff.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Tacomarunner is offline  
post #3 of 59 Old 08-10-2007, 01:03 AM Thread Starter
Member
 
Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
what do you mean.
tj1974 is offline  
post #4 of 59 Old 08-10-2007, 05:02 AM
Compression Ignition Addict
 
Manatee's Avatar
 
Join Date: Nov 2006
Location: The Coastal Bend of Texas
Posts: 685
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by tj1974 View Post
what do you mean.
Since you asked: your post is one, long, run-on sentence with a bunch of misspelled words and grammar that does not work. None of us here are English professors buts your post "runs" a bit more than most

No big deal, Tacomarunner was just giving your post a bump to the top, just like I am.

Hope someone chimes in to help. I don't know too much about wrenching, but the blue smoke can't be good. Good luck

The Manatee

15 F350 Long Bed, Crew Cab, Lariat 4x4, 6.7 PSD
Manatee is offline  
post #5 of 59 Old 08-10-2007, 06:25 PM Thread Starter
Member
 
Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ok i did not think this was grammer school but ok the blue smoke is from the oil thats out of the turbo thank you for your concern with my spelling and run on EXCUSE ME
tj1974 is offline  
post #6 of 59 Old 08-10-2007, 06:34 PM
Premium Member
 
WEWILLE's Avatar
 
Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hey its ok they were just bumping your post back to the top. Does it run fine, with now smoke all the way up to 1000 and then it just stops reving, or just bad all the time? Just a wild guess egr cooler maybe? Is the truck still under warranty?

ASE Certified Master Automotive/light duty truck Technician
ASE light diesel specialist
Ford Certified Diesel Technician
Isuzu Certified Gas/Diesel Technician

2007 F-250 PSD FX4 crew cab shortbox king ranch
2005 F-250 PSD FX4 crew cab short Box burned up
2013 Fusion 1.6L Ecoboost
2011 Ford Edge
1999 Dodge 2500 Cummins
WEWILLE is offline  
post #7 of 59 Old 08-10-2007, 07:29 PM Thread Starter
Member
 
Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
no it is not under warranty an d i took the exhaust pipe off back of the turbo and it is full of oil and it does run fine and starts fine and no check engine light and no codes the oil i think should not be in the exhaust out of the turbo right it you can accelerate it but it will not go over 1000 rpm like no boost pressure
tj1974 is offline  
post #8 of 59 Old 08-10-2007, 08:01 PM
Member
 
Join Date: Apr 2007
Location: alberta,canada
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Maybe try removing and inspecting the egr valve to see if it is caked with carbon deposits or maybe stuck.
grabowskimech is offline  
post #9 of 59 Old 08-10-2007, 08:16 PM Thread Starter
Member
 
Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ok i thaught bout the egr but i cant seemed to get it pryed out where it is mounted i can turn it but it will not pry ou but what bout the oil in the exhaust tube that connects to the turbo i thaught that should be dry the egr is they a special way of getting it out?
tj1974 is offline  
post #10 of 59 Old 08-10-2007, 08:21 PM
Compression Ignition Addict
 
Join Date: May 2007
Location: America
Posts: 6,782
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
your turbo is done
2005F250 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome