power stroke diesel problems - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2007, 05:48 PM
Member
 

Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
power stroke diesel problems

i have an 03 ford f 250 6.0 power stroke diesel and it will not accelerate over 1000 rpm and if you try to drive it it has no power it whistle really loud so i thaught the turbo be good and it smokes bad wht blue and i replace all the filters and replace the TP sensor and it is getting fuel dont know how much it starts fine runs fine and no check engine light and no codes could it be the turbo you can hold the accelerator to the floor and it will not go over 1000 rpm i have checked the tubes and every thing does any one have an idea what it could be
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-09-2007, 07:05 PM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: So Cal
Posts: 268
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Punctuation maybe?

Russell
Reply With Quote Quick reply to this message
  #3  
Old 08-10-2007, 12:03 AM
Member
 

Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what do you mean.
Reply With Quote Quick reply to this message
  #4  
Old 08-10-2007, 04:02 AM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: The Coastal Bend of Texas
Posts: 678
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by tj1974 View Post
what do you mean.
Since you asked: your post is one, long, run-on sentence with a bunch of misspelled words and grammar that does not work. None of us here are English professors buts your post "runs" a bit more than most

No big deal, Tacomarunner was just giving your post a bump to the top, just like I am.

Hope someone chimes in to help. I don't know too much about wrenching, but the blue smoke can't be good. Good luck
Reply With Quote Quick reply to this message
  #5  
Old 08-10-2007, 05:25 PM
Member
 

Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok i did not think this was grammer school but ok the blue smoke is from the oil thats out of the turbo thank you for your concern with my spelling and run on EXCUSE ME
Reply With Quote Quick reply to this message
  #6  
Old 08-10-2007, 05:34 PM
Premium Member
 

Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey its ok they were just bumping your post back to the top. Does it run fine, with now smoke all the way up to 1000 and then it just stops reving, or just bad all the time? Just a wild guess egr cooler maybe? Is the truck still under warranty?
Reply With Quote Quick reply to this message
  #7  
Old 08-10-2007, 06:29 PM
Member
 

Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no it is not under warranty an d i took the exhaust pipe off back of the turbo and it is full of oil and it does run fine and starts fine and no check engine light and no codes the oil i think should not be in the exhaust out of the turbo right it you can accelerate it but it will not go over 1000 rpm like no boost pressure
Reply With Quote Quick reply to this message
  #8  
Old 08-10-2007, 07:01 PM
Member
 

Join Date: Apr 2007
Location: alberta,canada
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Maybe try removing and inspecting the egr valve to see if it is caked with carbon deposits or maybe stuck.
Reply With Quote Quick reply to this message
  #9  
Old 08-10-2007, 07:16 PM
Member
 

Join Date: Aug 2007
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok i thaught bout the egr but i cant seemed to get it pryed out where it is mounted i can turn it but it will not pry ou but what bout the oil in the exhaust tube that connects to the turbo i thaught that should be dry the egr is they a special way of getting it out?
Reply With Quote Quick reply to this message
  #10  
Old 08-10-2007, 07:21 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
your turbo is done
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:35 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors