6.0 lack of power while towing??? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-09-2007, 10:31 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 lack of power while towing???

Hi guys this is my first post. I have a 6.0 2006 f250 with a banks six gun anf 4" turbo back exhaust. running 35" tires with 373 gears. I pull a 31' traveltrailer that comes in at 8,000 lbs. my truck seams to have a real problem towing this up any kind of grade. I have to get a run at hills to only have it loose MPH. It will then down **** hit around 2500 RPM's and hold there or decelerate.I can never gain and speed,while my buddy in his dodge pulling a 37' 5th wheel blows right by me. I have to wait till of the hill and then I can start gaining speed again. Seams to rev just fine but not much power. Any idea's. I'm thinking bad turbo. ????????????????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-09-2007, 10:38 AM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,760
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Quote:
Originally Posted by Tmoneytrojan View Post
Hi guys this is my first post. I have a 6.0 2006 f250 with a banks six gun anf 4" turbo back exhaust. running 35" tires with 373 gears. I pull a 31' traveltrailer that comes in at 8,000 lbs. my truck seams to have a real problem towing this up any kind of grade. I have to get a run at hills to only have it loose MPH. It will then down **** hit around 2500 RPM's and hold there or decelerate.I can never gain and speed,while my buddy in his dodge pulling a 37' 5th wheel blows right by me. I have to wait till of the hill and then I can start gaining speed again. Seams to rev just fine but not much power. Any idea's. I'm thinking bad turbo. ????????????????
I am thinking possible clogged egr valve, or you need to clean the turbo. I am no expert on the 6.0L's. But if you are having low power issues from what I have read it usually seems to be the egr valve and the turbo needing cleaning. Being I never done this I have an Idea of what needs to be done to do the job. But it will be better for some one else that has more experince with the 6.0L then I to explain it. I am sure one of our great techs will be along soon to help you out.

Welcome to the Org. There is alot of great people on the site and alot of good info.
Reply With Quote Quick reply to this message
  #3  
Old 08-09-2007, 10:40 AM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
any codes? My first thought is dirty fuel filters, or a sticking turbo.....

How many miles on the truck and when was the last time the fuel filters were changed??
Reply With Quote Quick reply to this message
  #4  
Old 08-09-2007, 10:41 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks Big country, it's going into the dealer on monday, I'm just having a hard time with this.This is my first ford.
Reply With Quote Quick reply to this message
  #5  
Old 08-09-2007, 10:42 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Truck has 22,000 on it it has had 1 fuel filter change so far. no codes
Reply With Quote Quick reply to this message
  #6  
Old 08-09-2007, 10:44 AM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
what level are you towing on with the six gun??
Reply With Quote Quick reply to this message
  #7  
Old 08-09-2007, 10:46 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
between 3 and 4
Reply With Quote Quick reply to this message
  #8  
Old 08-09-2007, 10:47 AM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
try backing it down to 2 and see if that helps...
Reply With Quote Quick reply to this message
  #9  
Old 08-09-2007, 10:56 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i've tryed every setting even stock . it revs fine, never misses, just doesn't seems to have any pulling power. when I run it without the trailer on setting 4 it goes like a raped ape. it just happens when you put any type of load on it. I even noticed that when I pulled a empty 6x12 uhaul trailer it seemed sluggish.
Reply With Quote Quick reply to this message
  #10  
Old 08-09-2007, 11:00 AM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
see what the dealer says....sounds like a potentially binding turbo to me...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:00 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors