I thought 6.0's were ... - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-07-2007, 08:30 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I thought 6.0's were ...

I thought 6.0's were supposed to work 7.3's. Well mine doesn't. Dad and I were racing today. Me in my truck and him in his 2000 F350 CC/LB 4X4 7.3. Our trucks are dead even from a start or even rolling. I'm jealous because if my truck was faster then I wouldn't care that his truck poures more smoke and sounds better but now that I knoe there even I'm jealous.

Last edited by 2005F250; 08-04-2008 at 08:23 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-07-2007, 09:06 PM
Banned
 

Join Date: Jan 2007
Location: Goodyear, AZ
Posts: 2,083
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 2005F250 View Post
I thought 6.0's were supposed to work 7.3's. Well mine doesn't. Dad and I were racing today. Me in my truck and him in his 2000 F350 CC/LB 4X4 7.3. Well my truck is on 80hp over at the crank and his truck is on the 2nd setting of his edge evo. Our trucks are dead even from a start or even rolling. I'm jealous because if my truck was faster then I wouldn't care that his truck poures more smoke and sounds better but now that I knoe there even I'm jealous.

sounds like the old man has a good running 7.3. Also must be something wrong with your rig. With the PPE you should roll coal all over him. You have an issue somewheres. Get it fixed and you should beat him not problem . even on level 2 you have more HP stock than he does tuned
Reply With Quote Quick reply to this message
  #3  
Old 08-07-2007, 09:09 PM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I say sell the PPE and get an SCT. Then no worries
Reply With Quote Quick reply to this message
  #4  
Old 08-07-2007, 09:12 PM
Banned
 

Join Date: Jan 2007
Location: Goodyear, AZ
Posts: 2,083
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Logan View Post
I say sell the PPE and get an SCT. Then no worries
I agree but there is still something wrong. The PPE is a pretty aggressive tuner and should make plenty of power to smoke his old mans 7.3 on stage 2 with the evo
Reply With Quote Quick reply to this message
  #5  
Old 08-07-2007, 09:23 PM
Compression Ignition Addict
 

Join Date: Jan 2006
Location: Pittsburgh, Pa
Posts: 4,129
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The evo is a good tuner for the 7.3l. Its no custom, but many 7.3's run very good with them. If he is rolling big smoke I would have to call him on the stage 2 setting. The 80hp setting on the PPE is only about 60-65 hp at the rear wheels, but should still be plenty for a 7.3 if he is truely on stage 2. Turn the PPE up and show him who is BOSS!
Reply With Quote Quick reply to this message
  #6  
Old 08-07-2007, 11:24 PM
The Lady Mod


 

Join Date: Feb 2007
Location: Arkansas
Posts: 8,512
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Granny
Quote:
Originally Posted by Logan View Post
I say sell the PPE and get an SCT. Then no worries
Ditch the PPE and get an SCT!!!!
Reply With Quote Quick reply to this message
  #7  
Old 08-08-2007, 03:39 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: America
Posts: 6,783
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Well I have a 1744 code. My torque converter locks and unlocks but it's bad in O.D. so I'm probably loosing power there. I don't see why the torqshifts are such a great tranny. I'm on my third that has been rebuilt. - All under warranty and last rebuild was at 35,956 miles.
Reply With Quote Quick reply to this message
  #8  
Old 08-08-2007, 05:19 PM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
You may have something else going on that is causing you to eat trannies. I have not had any problem out of mine and I am around 75k. Something else maybe needs to be checked. Get it to Marc and let him have a look see at it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:12 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors