problems on a 03' 6.0!!!!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-31-2007, 11:51 AM Thread Starter
Serving Our Country!
 
sawyer1's Avatar
 
Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
problems on a 03' 6.0!!!!!

Its not mine but its my dads, Hes got 72,000 miles and when he starts his truck in the morning allows it to warm up (15-20min) and takes off it just doesnt run good its almost as if the turbo isnt spooling up, then 3-4 miles down the road it runs fine like a 6.0 should has tons of power after the 3-4 miles. He is totally stock has already changed fuel filter, air filter and his egr valve is clean and working, he also unplugged it to see if that made a difference but no luck problem has been going on for a while so any help will be much appreciated. Thanks for the help!!!
sawyer1 is offline  
post #2 of 3 Old 07-31-2007, 12:18 PM
Emergency Services
 
dustindiesel's Avatar
 
Join Date: Oct 2006
Location: tampa, florida
Posts: 1,071
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i believe there is a reprogram update for cold performance issues..got to take it to the dealor and they will reflash it


2003 psd 6.0
red crewcab
16" suspension lift, 48" michelin xml's on 20x10 black rockstars, 6000k hid's, crossover steering, zoodad mod, ccv mod, modified up pipe to delete egr cooler,high idle mod, mbrp 3.5 downpipe, train horns(also on remote), diamond plate tool box, recon smoked cablights, Code670 alarm/remote start,100w reverse lights, oil-based underbody paint
**soon to purchase SCT rockwell 2.5 ton frt/rear
-8,520lbs with me in it
dustindiesel is offline  
post #3 of 3 Old 07-31-2007, 12:34 PM Thread Starter
Serving Our Country!
 
sawyer1's Avatar
 
Join Date: Jul 2007
Location: Great Falls, MONTANA
Posts: 1,164
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks i let him know hopfully that will be the problem.
sawyer1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome