rough idle after start til warm,block plugged in too - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 01-07-2011, 09:30 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
rough idle after start til warm,block plugged in too

I have o4 6.0 liter. It was also coughing out black exhaust til it warmed up as well. Engine missed once on the highway. It would start fine all day. But when left over night it would start rough again. Now she just turns over with the odd fire every few attempts but quickly stalls. This all started shortly after a oil change at quick oil change shop. Another funny thing is that obd 2 tool wont even link to my truck to pull codes. Any idea's?
Hutch0435060 is offline  
post #2 of 5 Old 01-09-2011, 03:13 PM
Powerstroke.org Rookie
 
rizzlebizzle's Avatar
 
Join Date: Jul 2010
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If the scan tool won't link to your truck you might have an issue with the PCM. That would effect injection control as well.
rizzlebizzle is offline  
post #3 of 5 Old 01-10-2011, 12:25 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Figured out the OBD 2 problem, but it's still not giving me any codes. Should I be getting some RPM's while cranking. I've already changed fuel filters, checked my FICM voltage, egr valve. I guess I'm looking at a tow to the shop if it is my PCM.
Hutch0435060 is offline  
post #4 of 5 Old 01-11-2011, 04:02 PM
Powerstroke.org Rookie
 
rizzlebizzle's Avatar
 
Join Date: Jul 2010
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
With the OBD link fixed, you probably have an injector sticking. They can be cleaned, I don't know if you're up to the job yourself. I'm pretty sure there is a tech file on cleaning the injectors somewhere.
rizzlebizzle is offline  
post #5 of 5 Old 01-11-2011, 04:48 PM
Powerstroke.org Rookie
 
powerstroke137's Avatar
 
Join Date: Jan 2011
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
PCM, Ficm and or EGR issues plus have the injectors tested if you can make sure who ever does them do not do a buzz test does not work on 6.0 wont give you the right result
powerstroke137 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome