Glow plug system problems - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-25-2010, 04:58 AM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Location: Northern NY
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation Glow plug system problems

I have a 04 F550 6.0. I am getting codes P0671-678 (glow plugs cyl 1-8). Tested all glow plugs just to be safe and all are good like I assumed they would be. Replaced GPCM as advised by Ford dealer. Still not fixed and still throwing all same codes. Testing resistance on all wires as per alldata today. Has anyone else had this problem?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-28-2010, 08:20 AM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Location: Northern NY
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone have any ideas?
Reply With Quote Quick reply to this message
  #3  
Old 01-02-2011, 01:00 PM
Member
 

Join Date: Jul 2010
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
how do u get the clip off to test the glow plugs its giving me a hell of a time?
Reply With Quote Quick reply to this message
  #4  
Old 01-02-2011, 06:51 PM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Location: Northern NY
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the plug on the intake has a little clip locking it together. the connectors on the plugs just pull off and the connectors on the glow plug module unclip very hard. Try to push in with a screwdriver while pulling on the plug. It worked for me
Reply With Quote Quick reply to this message
  #5  
Old 01-02-2011, 10:08 PM
Member
 

Join Date: Jul 2010
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
alright thanks
Reply With Quote Quick reply to this message
  #6  
Old 01-03-2011, 10:45 AM
Powerstroke.org Rookie
 

Join Date: Oct 2010
Location: Northern NY
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
took it to the dealer. they said it needs 8 glow plugs and both harnesses. I think they just said it needs that that because that is all that is not new. I guess Ill do that and see if its better
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
glow plugs, gpcm, hard start, start

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors