!! 911 !! TRUCK WON'T SHUT OFF! - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-19-2010, 08:27 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Nov 2009
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation !! 911 !! TRUCK WON'T SHUT OFF!

Great first day after getting married

I have an 05 psd and this morning I got in it and turned the key to warm up the glow plugs... the GP light never turned on, edge also didn't turn on like it should whenever I turn the key on. I started the truck and it fired with no problem (despite it being 5 deg outside) I let it warm up about 15 min then while driving it I realized my speedo wasn't working, and none of the info on my edge is changing. Got it home and turned the key off... truck didn't even hiccup, just kept on going, all gauges went to zero tho. Turned the key back on and the start sequence check lights came on then went off like normal, but the truck was running the whole time (still no GP light tho). I tried pulling a number of fuses to kill it such as: "engine control" "PCM" "ignition switch" "ignition switch off/run/start"... but the truck kept chuggin'. I finally pulled the fuel pump fuse and it died immediately. I have to leave that fuse out tho because as soon as i put it back in I can hear the fuel pump running.

My plan now (when time permits) i'm going to remove all my edge stuff (its a juice platinum with attitude A2 monitor) and see if that fixes the problem... if it doesn't, I have no idea what to do next...

PLEEEAASSEEEE HELP!

Thank you TONS in advance for any advice
Montana250 is offline  
post #2 of 3 Old 12-19-2010, 09:39 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Nov 2009
Posts: 127
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
UPDATE:

So I pulled out the edge module and plugged the factory plugs into the factory sockets. I put the fuel pump fuse back in and it doesn't run without the key on (good sign) and the glow plug light comes on with the key (also good sign) but, since the engine control systems clearly never shut off earlier, my batteries are dead, so I can't even try and start it. Put the charger on there and i'll update again after I let 'er charge for a couple hours.
Montana250 is offline  
post #3 of 3 Old 03-02-2011, 09:07 AM
Powerstroke.org Rookie
 
Join Date: Sep 2007
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had to remove my Edge too, Edge told me that ford had basically made it obsolute right after I bought it and that it was bad that I had continued to drive it.

Offered to sell me a new one for 700, no more Edges for me.
digesterman is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome