Exaust haze. - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-12-2010, 11:13 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Bucks County PA
Posts: 1,344
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exaust haze.

I bought my second 6.0 used with 108k. The truck had a 100% flawless oasis report, not a single warranty claim but by the time the used car dealership I bought it from got a hold of it it needed some maintenance. Before they sold it to me they said it needed some repairs from Ford. I got the work order for the truck and they paid thousands out of pocket on the truck repairs. Many new egr components, oil cooler, cleaned the intake manifold, new turbo, 4 new injectors, and some other minor stuff. The truck runs very strong, it tows a dump trailer daily. Only mods are True Flow foam filter, upgraded inter cooler piping and 4inch straight piped exhaust with stacks. The truck occasionally emits a white haze from the exhaust while driving and idling, a few times its been more than a haze. It doesn't smell bad, coolant level is fine and the truck has never puked. The truck now has 124k on it, any ideas?

Last edited by jwsland; 12-12-2010 at 11:17 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-13-2010, 03:18 AM
<-Day Of Fail now SOLD

 

Join Date: May 2008
Location: Japan
Posts: 3,393
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If its only at idle and random, kind of sounds like and injector is on its way out.
Reply With Quote Quick reply to this message
  #3  
Old 12-18-2010, 11:15 AM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Bucks County PA
Posts: 1,344
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm not ruling it out but everything was checked by the dealer and a few of the injectors replaced. It sometimes does while driving too. Any other thoughts?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors