Missing and Sputtering - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-12-2010, 06:16 PM
Premium Member


 

Join Date: Dec 2010
Location: Carthage
Posts: 298
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Missing and Sputtering

Hello fellow 6.0 owners,

I am new to the forum and I just wanted to say this place is like Google for a ford truck owner. This site is GREAT and hopefully I can save myself some time and money by learning from your knowledge and experiences.

Here is my problem; about a year ago my 6.0 was puking oil into my degas bottle. I took it in to my local (reputable) diesel mechanic and had the oil cooler replaced and the EGR and turbo cleaned and I believe they flashed the computer. Truck (04' F250 4x4 crew cab long bed with 220,000 miles on it) ran good until about two or three weeks ago. It has started skipping and sputtering. I thought maybe it was the fuel and or fuel filters, changed them and problem still exists. now that its winter I start it up to let the engine warm up but have noticed that even if the defrost is on hot/high the cab does not warm up. It does blow a little white smoke at start up but other than that just the normal black smoke if I lay on the pedal at high speeds. Mechanic said it could be a head gasket problem?????????? In my experience the symptoms donít fit head gasket failure. I did some looking around on this site and seen everything from EGR Delete kit to fuel injectors as a fix. There are no codes or dash lights on other than my water in fuel light.

Could a bad thermostat cause this sputtering?

Could it be a clogged EGR valve?

What are your thoughts on an EGR Delete kit? (I wish I would have known about this when I had my oil cooler replaced)

Has anyone done an EGR Delete kit? (which brand do you recommend)

Any help or info would be greatly appreciated!

Thanks!

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-14-2010, 02:47 AM
Premium Member


 

Join Date: Dec 2010
Location: Carthage
Posts: 298
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Any suggestions?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors