Coolant/Oil leak? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 12-09-2010, 06:23 PM Thread Starter
Serving Our Country!

 
f250ghost's Avatar
 
Join Date: Oct 2007
Location: Navarre, FL
Posts: 2,534
Thanks: 4
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to f250ghost Send a message via MSN to f250ghost Send a message via Yahoo to f250ghost
Coolant/Oil leak?

So I've had an oil leak for a few months now...its mainly running down the left side of the bell housing and dripping down. Well today at work after the truck has sat in 30* weather for about 5 hours it started leaking coolant...from the exact same spot on the bell housing. Like...the coolant was landing in the exact same spot as the oil. Once I started the truck and got it warm the leak stopped....

The coolant bottle has been removed/installed about 6 times this year due to injector work (we all know about that)...dunno if that has anything to do with it though.

any ideas?

-Ben
2011 F250 FX4
6.7 PowerStroke
f250ghost is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 12-09-2010, 06:32 PM
Compression Ignition Addict
 
scotty2280's Avatar
 
Join Date: Nov 2006
Location: forest lake, minnesota
Posts: 2,290
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
do you have a coolant filter?

studs,egr delete(sinister),dieselsite coolant filter, nuc oil bypass, dj's fuel + regulated fuel return, sct by eric, 4in silverline no cat, isspro gauges, cat elc coolant, hids, lots of other odds and ends......
scotty2280 is offline  
post #3 of 4 Old 12-09-2010, 06:36 PM Thread Starter
Serving Our Country!

 
f250ghost's Avatar
 
Join Date: Oct 2007
Location: Navarre, FL
Posts: 2,534
Thanks: 4
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to f250ghost Send a message via MSN to f250ghost Send a message via Yahoo to f250ghost
Quote:
Originally Posted by scotty2280 View Post
do you have a coolant filter?
Nope no coolant filter...

Oh, and the truck has 153k miles on it. Its been run hard here lately, 1600 miles for a trip to texas, and 1700 miles for the trip i took to indiana. Within a 2 month span.

-Ben
2011 F250 FX4
6.7 PowerStroke
f250ghost is offline  
post #4 of 4 Old 12-11-2010, 09:36 AM
Powerstroke.org Fanatic
 
Join Date: Apr 2010
Location: Wakefield
Posts: 115
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
sounds like it just leaks under pressure before the t-stat opens.. i would check the hoses to the heater core first... there is a coolant line the runs over the motor on the upper firewall that might be leaking.... or check the hose that runs to your egr cooler if you have one...
lacooks is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome