anyone have any ideas? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-08-2010, 07:00 PM Thread Starter
Compression Ignition Addict
montana6.0's Avatar
Join Date: Jun 2009
Posts: 525
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
anyone have any ideas?

ok so my truck just recently started doing this since some cold weather hit single digits. it happens when i go over speed bumps and turn sharp corners it makes a whining noise kind of like the powersteering or something not real sure it is that though. fluid is full and no leaks. i did notice a slight leak out of what seems to be a break line by the degas bottle fixed that but still makin noise. sorry for the long post. any help would be appreciated.

2010 F350 auto
2inch leveling kit
35'' toyo m/ts
20'' montsers
dpf cat delete
h&s mini Max
s&b cai
montana6.0 is online now  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome