Smoke and rough running - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 12-07-2010, 04:03 PM Thread Starter
Premium Member
 
Mwhitt002's Avatar
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Smoke and rough running

Blowing a gray/white smoke under normal acceleration and when you punch it the truck would run rough and even stalled once, not sure the problem..
Mwhitt002 is offline  
post #2 of 6 Old 12-09-2010, 01:58 PM
Member
 
Cobiaman's Avatar
 
Join Date: Feb 2010
Location: Houma LA
Posts: 41
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
In relation to your smoke I had white smoke for approx. 1yr. Kept going to dealership with nothing being found until my EGR cooler busted and fluid was in my exhaust but here is the kicker the whole time I kept smelling burnt oil. When I got it back a week later still smokin almost worse turns out to be the turbo seal was cracked allowing oil in the exhaust hence the burnt oil smell. Thought all was well but a week later doing the same thing turns out the new turbo seal was busted. Finally fixed and doing well. Hope this helps you out.
Cobiaman is offline  
post #3 of 6 Old 12-09-2010, 02:03 PM
Compression Ignition Addict
 
!!!PainTrain!!!'s Avatar
 
Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
First thing I would do is try and rule out the EGR cooler/valve.

Try parking the truck with the nose slightly downhill. Then pull out the EGR valve. If the intake below the valve is wet then you know you have a leaky cooler and that cold be the source of your white smoke.

Performance: SCT Xcal-Innovative Diesel, 4" Turbo Back Exhaust no muffler and kitty missing, Spearco IC, ID Power Elbow, AFe Stg. II Intake, 03 Turbo.
Exhaust Clip:http://www.youtube.com/watch?v=mYF9HgB0RwY

Looks: Westin Black Powder Coated Bull Bar, Recon Smoked Cab, Mirror Lights, and 3rd Brake Light, 4" Superlift kit, 35" ProComp Extreme A/T's, 18x10 Diamo Black & Chrome Rims.
!!!PainTrain!!! is offline  
post #4 of 6 Old 12-10-2010, 08:19 AM
Compression Ignition Addict
 
Chango's Avatar
 
Join Date: Nov 2010
Location: San Diego, CA
Posts: 310
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ill ask the general dumb question. Have you changed your filters recently?

Awesome thread on oil / cold start issues for 6.0 ----> http://www.powerstroke.org/forum/gen...ably-like.html
Troubleshooting a no Start Condition ---> http://www.powerstroke.org/forum/6-0...condition.html
Still using Ford Coolant? ----> http://www.powerstroke.org/forum/6-0...nce-temps.html
Chango is offline  
post #5 of 6 Old 12-10-2010, 03:08 PM Thread Starter
Premium Member
 
Mwhitt002's Avatar
 
Join Date: May 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yeah i thought it might be the filters also and i changed them still didnt work, but i took it to the ford truck repair place and they said 2 injectors went but they wanted way too much to fix it. im now exploring my opions for places to fix them. thanks for the help though
Mwhitt002 is offline  
post #6 of 6 Old 12-10-2010, 03:14 PM
Compression Ignition Addict
 
!!!PainTrain!!!'s Avatar
 
Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by Mwhitt002 View Post
Yeah i thought it might be the filters also and i changed them still didnt work, but i took it to the ford truck repair place and they said 2 injectors went but they wanted way too much to fix it. im now exploring my opions for places to fix them. thanks for the help though
Did you check the EGR valve?

Performance: SCT Xcal-Innovative Diesel, 4" Turbo Back Exhaust no muffler and kitty missing, Spearco IC, ID Power Elbow, AFe Stg. II Intake, 03 Turbo.
Exhaust Clip:http://www.youtube.com/watch?v=mYF9HgB0RwY

Looks: Westin Black Powder Coated Bull Bar, Recon Smoked Cab, Mirror Lights, and 3rd Brake Light, 4" Superlift kit, 35" ProComp Extreme A/T's, 18x10 Diamo Black & Chrome Rims.
!!!PainTrain!!! is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome