2005 Wont start!!!!!!!!!!! help!!!!!!!! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-01-2010, 05:53 PM
Powerstroke.org Rookie
 

Join Date: Jun 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 2005 Wont start!!!!!!!!!!! help!!!!!!!!

I have a 2005 4x4 f250, my edge evolution tuner pulled a crankshaft position sensor fault so I replaced it and also replaced the cam shaft position sensor. Still does not start, will crank and crank but will not start. has a p1378 unknown error fault. have been told it might be the glow plug relay and if so does anyone know where it is at and how to test it? also the other idea I have been given is the fuel injection control module, and would like to find out where this is at and how to test it. Would hate to send my truck to the shop because I have never done that but this is my first diesel and im lost at this point, any help would be greatly appreciated. reply to thread or email keithstang96@yahoo.com
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-02-2010, 05:15 AM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 17,117
Thanks: 13
Thanked 48 Times in 37 Posts
Feedback Score: 4 reviews
That is your Fuel Injection Control Module (FICM) and is located on your driver's side valve cover. (It's a silver rectangle with three connectors underneath.) The connectors are kind of difficult to disconnect if you have never done it and sometimes brittle due to the heat load of the engine. Here's a link below to some reading about the FICM.

LINK
Reply With Quote Quick reply to this message
  #3  
Old 12-02-2010, 05:54 AM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Brewster, NY
Posts: 1,180
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just a thought, check your fuses, and the ones under the hood. Maybe low voltage on the batteries too?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:42 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors