No Heat on an 05 - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-21-2010, 10:34 AM
Banned
 

Join Date: Mar 2010
Location: alabamer
Posts: 1,078
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to harley1rocker Send a message via Skype™ to harley1rocker
No Heat on an 05

Truck heater is not working. Coolant is good, thermostat is opening, everything looks good, A/C is working fine just no heat.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-21-2010, 01:39 PM
Member
 

Join Date: Dec 2007
Location: San Diego CA
Posts: 68
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
There is a coolant shut off valve on the heater supply hose. Did you check to see that this is open? If this is working then I am only guessing that maybe you heater core is clogged.
Reply With Quote Quick reply to this message
  #3  
Old 11-21-2010, 03:54 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,380
Thanks: 23
Thanked 89 Times in 79 Posts
Feedback Score: 4 reviews
theres a little butterfly valve on the inlet heater hose under the hood. i see these freeze up and the actuator arm breaks off. i don't know how much rust you get down there but it's common up here
Reply With Quote Quick reply to this message
  #4  
Old 11-25-2010, 09:35 AM
Member
 

Join Date: Sep 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i was just lookin at mine , on one side of the valve i have a warm hose the other side cold .could it be this valve its the one with the little grey vacuum line . any help !!!!strokedis
Reply With Quote Quick reply to this message
  #5  
Old 11-25-2010, 10:21 AM
Member
 

Join Date: Sep 2010
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just fixed for now , tied the valve open for now .need to get valve tomorrow had my son cycle the knob in the truck it didn't throw the valve in full open position .i'm thinkin just valve or could i still have a vacuum leak somewhere!!!STROKEDIS
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:53 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors