charging problem! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-20-2010, 03:31 PM Thread Starter Rookie
Join Date: Nov 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question charging problem!

i have a 2003 f-250 with the 6.0 and i cant seem to figure out my charging problem. i went out to leave for work and the truck was stone dead. i jumped it and it ran all day with no problems. i parked it for a few hours and went to start it and it started no problem. went back 20 minutes later and it was dead. i pulled the alternator off and went to autozone and had it tested and it tested good four times. i then pulled out the batteries and they were both bad. i put two new batteries in and both batteries were holding 12.2 to 12.6 volts not running then while the truck ran the alternator was only showing putting out 12.2 volts at idle, at 2000 rpms it put out 13.2 to 13.4 volts. i bought a new alternator and it put out the same volts. i checked the fusible links and wires and they all seemed to bwe good . im stuck and at a loss! if anyone has any ideas id appreciate it! thank you
broncoking351 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome