Need Help Fast! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-16-2010, 11:06 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2010
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need Help Fast!

I recently bought a 2004 F250 King Ranch with the 6.0 Diesel. The only work I've ever done on diesel motors was mostly maintenance on big farm tractors. Since I bought the truck, I've replaced both batteries and the alternator (1 of the batts was bad and the alternator had a diode stuck open). It ran fine for about a week. This past Sunday, it wouldn't start. It turns over, but it sounds like the batteries are almost completely dead. Took out batteries and alternator and got tested at Advance. They all read good. Put them back in truck, tried to jump it off, still the same thing. It turns over every time, but just VERY weak. Could this be the starter even though it's actually turning over some, or is there something else it could be?????
brownf is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-16-2010, 01:42 PM
Compression Ignition Addict
 
atvrider93's Avatar
 
Join Date: May 2010
Location: Raleigh, NC
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 12
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
could be the starter but more likely a loose battery cable or starter wire somewhere
atvrider93 is offline  
post #3 of 4 Old 11-16-2010, 03:49 PM
Compression Ignition Addict
 
Join Date: Jun 2009
Posts: 692
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm with ATVRIDER93

Former 6Leaker owner
Newman is offline  
post #4 of 4 Old 11-17-2010, 12:00 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2010
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yep it was the starter. Got it put in and cranks like new! I can tell now that its been bad since I bought the truck, bc it cranks like never before with this new one!!
brownf is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome