New exhaust, jet sounds? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-10-2010, 06:46 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2010
Location: Portland
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New exhaust, jet sounds?

I just put on the 4" MBRP kit with cat and muffler delete (very easy, took 2 hours tops) and i was expecting allot more sound out of it however it doesnt get much louder until i get to about 2000 RPMs which i read was normal. However when i first start it if i walk around to the tailpipe it almost sounds like a mix between a jet and exhaust brake. Checked for leaks at clamps nothings leaking its all out of the tailpipe. I dont have an exhaust break. Once its warmed up its a little less but still screams at idle. I have the SCT X3 with factory performace programmed as of now. Is this normal? I'm thinking just a pararnoia question but i wanted to be sure. This is my first diesel and new exhaust experience. btw those of you who were considering it i would recommend it. takes away allot of turbo lag. Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-10-2010, 06:48 PM
Compression Ignition Addict
 

Join Date: Jul 2010
Location: Cincinnati
Posts: 4,195
Thanks: 6
Thanked 36 Times in 35 Posts
Feedback Score: 13 reviews
mine sounds like that, i thinks its bada$$
Reply With Quote Quick reply to this message
  #3  
Old 11-10-2010, 06:53 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,669
Thanks: 86
Thanked 184 Times in 148 Posts
Feedback Score: 3 reviews
Welcome to Powerstroke.org!!!The jet sound is normal after a kitty/muff delete.
Reply With Quote Quick reply to this message
  #4  
Old 11-10-2010, 06:55 PM
back to business



 

Join Date: Oct 2007
Location: Not AK right now
Posts: 3,561
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Normal.


What year is your truck?
Reply With Quote Quick reply to this message
  #5  
Old 11-10-2010, 06:59 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Barnwell/Bluffton, SC
Posts: 5,268
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Send a message via AIM to southern7.3
Straight piped 6.0 sounds about right
Reply With Quote Quick reply to this message
  #6  
Old 11-10-2010, 07:03 PM
Compression Ignition Addict
 

Join Date: Apr 2010
Posts: 2,044
Thanks: 0
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
yup normal, its due to your VGT (variable geometry turbo)
Reply With Quote Quick reply to this message
  #7  
Old 11-10-2010, 07:05 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2010
Location: Portland
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
perfect thanks exactly what i wanted to know. and its a 2004, i just bought it a 3 weeks ago from a dealership here. the second day i had it the tranny actually went out on me (6 speed) going to work in the morning. it took them 2 and a half weeks to get it back to me. the replaced it with a brand new one which was nice.5700 i didnt have to spend! i thought that was kind of early for only 92000 miles
Reply With Quote Quick reply to this message
  #8  
Old 11-10-2010, 07:24 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,669
Thanks: 86
Thanked 184 Times in 148 Posts
Feedback Score: 3 reviews
If it's early '04 then you have a '03 turbo.
Reply With Quote Quick reply to this message
  #9  
Old 11-10-2010, 07:25 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2010
Location: Portland
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
and from what i've read thats good news correct?
Reply With Quote Quick reply to this message
  #10  
Old 11-10-2010, 07:27 PM
back to business



 

Join Date: Oct 2007
Location: Not AK right now
Posts: 3,561
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Only if you like the noise your new exhaust makes........
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:23 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors