Click,click,click - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-12-2007, 12:55 PM Thread Starter
Compression Ignition Addict
 
CLIPPERS's Avatar
 
Join Date: May 2007
Location: NE Missouri
Posts: 352
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Click,click,click

There is a sound coming from my right front that sounds like there is a rock in the tire, but there isn't one. I have checked several times for a rock or nail, but that isn't it. I have locked the hubs in and it still does it. Any ideas? Its not that loud, you can only hear it when there's not much motor noise or when driveing beside a building or parked cars. I guess the sound resonates off of those. THANKS!

2003 F250 6.0 CrewCab 4x4 XLT
Stock

CLIPPERS is offline  
post #2 of 4 Old 06-12-2007, 12:59 PM
Compression Ignition Addict
 
cj41foley's Avatar
 
Join Date: Dec 2006
Location: Tuscaloosa Alabama
Posts: 1,770
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
pull the tire off and check the brakes

Jason
2006 F250 2wd 6.0 psd, 8.96 1/8th mile with canned SCT tunes, now running Spartan Hybrid Race tune! AFE Stage 2 PRO DRY S, 4" turbo back str8 pipe in front of rear tire, auto, crew cab short bed, ZOO DAD mod, 5% tint over the factory tint.
Track Times!
Reaction---.674
60 ft-------1.892
594 ft------8.370
1/8th ET---8.965
1/8th MPH--75.63
cj41foley is offline  
post #3 of 4 Old 06-13-2007, 09:00 AM Thread Starter
Compression Ignition Addict
 
CLIPPERS's Avatar
 
Join Date: May 2007
Location: NE Missouri
Posts: 352
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
For wear or tightness?

2003 F250 6.0 CrewCab 4x4 XLT
Stock

CLIPPERS is offline  
post #4 of 4 Old 06-13-2007, 09:08 AM
M4 in my tool box
 
Pullinpower7.3's Avatar
 
Join Date: Nov 2006
Location: Glenburn, ND
Posts: 321
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
might also want to check the bearings in the hubs, i pulled the outside part of the hub on mine when it was making a rattling/clicking sound and they were dry, i filled the bearing up with grease and it went away. could try that, just dont lose any of the snap rings from inside and pay close attention to how it goes back together. hope this helps

2001 F-250 X-Cab 4X4, Edge EVO, DIY Tymar, Map Fooler, FPR Shimmed, 4" exhaust into 7" GR Bullhauler stacks, 3.5" fabtech lift,35x12.50 procomps, 18" DEJ cannon wheels, Custom built RobTrans, HD U-joints, Trip A-pillar Guages, 2 12" rockford subs 1500watt rockford amp and Eclipse head unit, More to come!
Proud USAF Vehicle Maintainer, With out US, YOU walk!
Pullinpower7.3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome