Fuel guage doesnt work? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 06-10-2007, 06:56 PM Thread Starter
Member
 
Join Date: Nov 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Fuel guage doesnt work?

Hi,
I have an 03 f-350. 6.0. I bought it rolled over and just got done welding the new top on. While driving around I noticed the fuel gauge does not work. I have the lariat edition and the over head computer seems to work. It was telling me I have 499 miles till empty. I did have the truck tarped most of the winter and the automatic 4x4 button is not working. Im wondering if I just got some water behind the dash and the fuse panel got a little wet or.......maybe some else has experiecnced a bad fuel gauge.

On a side note, worste case senario I do run out of diesel.....how do you get it started agian? I know my old 6.2 is a beast to get going agian.....
jeepguy88 is offline  
post #2 of 7 Old 06-10-2007, 07:09 PM
FJuanfiddy mod


 
Dave's Avatar
 
Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,836
Thanks: 132
Thanked 186 Times in 166 Posts
Mentioned: 1 Post(s)
Quoted: 9 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
With the PSD's if you do run out normally you can dump about 10 gallons into the tank and cycle the key a few times to pull fuel into the bowl and should start right up

Email: Dave@powerstroke.org
2011 F150 Ecoboost Crew cab lariat. Custom tunes from KEM and 5Star, and Unleashed
2012 F150 Crew Cab Ecoboost stock for now-Totaled March 12 2015
2006 F250 ECSB Lariat 4x4

Leveling kit, 315/70/17 Kelly TSRs on Method race wheels
ARP studs and OEM gaskets done by Renegade Diesel
ECM and Atlas 40 FICM tuned by Bill at PHP SCT tunes by Truck Source Diesel. Gearhead, Innovative, Wildman and Tyrant diesel
Flowmaster/MBRP Hybrid Exhaust
Edge Insight CTS
Coolant filter
Bulletproof diesel FICM EGR Delete, Oil Cooler and Water Pump, and Light bar.
Dually LED lights from Stealth Automotive/Xpedition Outfitters
No Limit Fab 6.0 Cold Air Intake
http://www.bulletproofdiesel.com/default.asp
http://nolimitfabrication.com/
Dave is offline  
post #3 of 7 Old 06-10-2007, 07:29 PM
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,604
Thanks: 9
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
with the electric fuel pumps in the new ones they arnt as hard to get started. If the truck was rolled over there is a good chance the sending unit was damaged.

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
post #4 of 7 Old 06-10-2007, 07:53 PM
Compression Ignition Addict
 
willypscustoms's Avatar
 
Join Date: Dec 2006
Location: Tucson,AZ
Posts: 2,191
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
try shooting it then it might work, jk
but on a serious note it might be a bad sending unit or bad wire, on all my fords the gas gauge has stopped working it usually was a bad sending unit or wiring. hope this helps.

IF CAPS ARE ON IM AT WORK I CANT TAKE THEM OFF
willypscustom cold air intake
4" exhaust straight piped
banks 6 gun
itp regulated return
dp tuner
9" lift 37" tires
agr hydro. assist steering
greddy turbo timer and greddy gauges
wicked wheel
and some other small mods
willypscustoms is offline  
post #5 of 7 Old 06-10-2007, 08:16 PM
Compression Ignition Addict
 
Join Date: May 2007
Location: America
Posts: 6,782
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You can try hitting it. When I have stuff that doesn't work I'll hit or kick it and if that doesn't fix it then I'll go further into it.
2005F250 is offline  
post #6 of 7 Old 06-13-2007, 01:53 PM Thread Starter
Member
 
Join Date: Nov 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yeah yeah......I will hit it with a hammer, and if that doesnt work I will hit it with a bigger hammer......why didnt I think of that.......

on a side note, I did take the negatives off the batteries yesterday and when I turned the truck back on I get a little reaction out of the fuel gauge. And the over head miles till empty started over at 500. Something aint right.

-Chad
jeepguy88 is offline  
post #7 of 7 Old 06-13-2007, 07:10 PM Thread Starter
Member
 
Join Date: Nov 2006
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I tried. Not much room between the tank and the bed.

Im starting be more concerned with the 4wheel drive not working. We took the swicth apart and it seemed to be good. There is power to the fuse. Is there a module or computer something or other I should be checking?
jeepguy88 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome