Sudden loss in power?! - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-07-2007, 07:38 PM Thread Starter
Join Date: Sep 2005
Location: SOUTH New Jersey (there is a difference)
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sudden loss in power?!

I'm driving my truck and noticed it just didn't kick like it has been. What could've happened. I'm coming up on 40,000 miles. Well earned miles on the trucks behalf haha but it doesn't have that kick in the pants.

any ideas?
for those who have ideas. boost is the same and everything is the same parameters. The truck is just reacting differently. I'm waiting till morning to see if anything is leaking... wow that would suck.

06TWO50Diesel is offline  
post #2 of 2 Old 05-07-2007, 08:33 PM
sootyoil's Avatar
Join Date: Mar 2007
Location: miami
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
are you using diesel fuel concetrate additive in evry fillup? fuel is
"timing" in a diesel engine
sootyoil is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome