trailer brake inop - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-09-2010, 01:18 PM Thread Starter
Member
 
RibbeRacing85's Avatar
 
Join Date: Jan 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
trailer brake inop

i have an 05 f350 6.0L with the factory trailer brake built into dash. it lights up when i turn the key on but when i plug my trailer into the truck the brake controller does nothing but the lights work on the trailer. any ideas as to why the controller wont power up? my father has a duramax and his controller works fine when plugged into the trailer

RibbeRacing85 is offline  
post #2 of 4 Old 05-10-2010, 09:09 AM
Compression Ignition Addict
 
rodmodder's Avatar
 
Join Date: Oct 2009
Location: Walworth County
Posts: 165
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I don't have any insight but mine doesn't work for crap either. I'd like to eliminate it and put in something else.



2005 F-250 4x4 CCSB
Straight piped, deleted, leveled and rockin 305's.
rodmodder is offline  
post #3 of 4 Old 05-10-2010, 09:39 AM
Compression Ignition Addict
 
Isakson's Avatar
 
Join Date: Mar 2010
Location: Missouri
Posts: 977
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
there must be a bad connectin somewhere. i have a 96 7.3 and when i plug in the lites for a gooseneck in, it works, but when i hook up the bumper lights it doesn't work

1996 F 350 7.3L 4x4 226,000 Miles on the Clock and Still Tickin!
Edge Evolution: Extreme
SUPERDUTY SEATS
Kobalt Tool Box




Isakson is offline  
post #4 of 4 Old 05-10-2010, 09:43 AM
Compression Ignition Addict
 
SD350's Avatar
 
Join Date: May 2010
Posts: 190
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Are you using an adapter? because mine did the same thing until i opened up the adapter and switched two wires around that control the brakes, now it works like a champ.
SD350 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome