lost power wont start - Ford Powerstroke Diesel Forum

6.0L Problems Forum Having Trouble? Post here

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-30-2010, 06:49 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
lost power wont start

Hello all! I have a 2005 f350 94,000 miles, while pulling a trailer the other day i heard a pop and lost all power! Had a buddy pick the trailer up and limped it home with barely enough power to get it there, now it wont even start at all! Not getting any codes with a snap on scanner. Any help will be greatly appreciated!!!!! Thanks in advance
shawyer502 is offline  
post #2 of 2 Old 05-03-2010, 05:47 PM
Member
 
HankHill's Avatar
 
Join Date: Feb 2010
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
did you check the turbo to intercooler boot that would be my guess


2003 (build date 06/2003) f250, 6.0 stroke, automatic, 4x4, 3.73 GR, bought with 96k miles, ficm resolder, ccv mod, coolant filter, powersteering filter, straight pipe
HankHill is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome