04 6.0 has issues - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-18-2010, 10:47 AM
Powerstroke.org Rookie
 

Join Date: Apr 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04 6.0 has issues

I bought this 04 F250 in september of 09 it had 50,xxx miles on it. up until i bought this all ive owned has been GM but i decided i need something with more pulling power and a solid front axle. since i bought it i have had it in the the shop for a new oil cooler and egr cooler, which took the dealership 2 monthes to get finished. 2 days ago i towed a rolling chassis 74 nova on a 18ft trailer 90 miles and the "powerchoke" as one of my buddies called it almost didnt make it. when i got to his house it started overheating and spewing a crap green sludge out of the coolant reservoir if anyone can give me a clue as to what caused this so i can get it fixed. i plan on keeping this truck for a while but if the 6.0 keeps causeing me problems im gonna yank it and the autotrans out and drop a 7.3 and a 6sp standard in it. i appreciate any advice or help. thanks
Semper Fi
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-20-2010, 10:53 AM
Powerstroke.org Fanatic
 

Join Date: Apr 2010
Posts: 116
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 04PowerstrokeMarine View Post
I bought this 04 F250 in september of 09 it had 50,xxx miles on it. up until i bought this all ive owned has been GM but i decided i need something with more pulling power and a solid front axle. since i bought it i have had it in the the shop for a new oil cooler and egr cooler, which took the dealership 2 monthes to get finished. 2 days ago i towed a rolling chassis 74 nova on a 18ft trailer 90 miles and the "powerchoke" as one of my buddies called it almost didnt make it. when i got to his house it started overheating and spewing a crap green sludge out of the coolant reservoir if anyone can give me a clue as to what caused this so i can get it fixed. i plan on keeping this truck for a while but if the 6.0 keeps causeing me problems im gonna yank it and the autotrans out and drop a 7.3 and a 6sp standard in it. i appreciate any advice or help. thanks
Semper Fi
Not a tech but I just had the same issue with mine and it was the oil cooler. Deleted the EGR cooler, rebuilt the oil cooler, and did a radiator flush. I don't know if its common but my oil cooler had busted and was mixing water and oil and whatever else was in the cooling system. Took me 12 attempts at flushing it all out. I wonder if the ford house flushed your radiator system after installing the oil cooler. The ford house in Houston that replaced the oil cooler before i purchased mine didn't and thats why 3 weeks into owning the truck with maybe 12k miles i had to do it myself. Like I said though I am not a tech or a mechanic just a monkey with a wrench passing on what happened with mine. Good luck with it though I know its a pain in the arse!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors