speedometer problem??? gets stuck? - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 04-11-2010, 02:54 AM Thread Starter
Compression Ignition Addict
 
Join Date: Jan 2010
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
speedometer problem??? gets stuck?

So i just got my truck, and the first day the speedometer starts giving me problems.

this morning it got stuck at 40mph and would not go past 40 or below 40. than i shut off truck and it corrected itself. then on the drive home, i gave it a good little push and i maybe got to 50mph but the speedo shot to 80mph and stuck their, now it basically treats 0mph as "70" and moves accordingly from there. 30=100 50=past 100 60=1" past 100 etc etc

shutting off the truck, now does not correct itself.


what can i do???
ONE_LO_SVT is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 04-11-2010, 04:43 AM
assistant director

 
thbd77's Avatar
 
Join Date: Feb 2007
Location: Springfield, TN
Posts: 1,053
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
unhook the batteries for 10 to 15 minutes. My dads truck does it every now and then. I believe they say the speedometer cluster is bad.

Name-Troy Lincoln
96 F-250 4X4 stroked xcab shortbed 5 speed
01 EXCURSION LIMITED 4X4 V-10 brute force intake dual exhaust
02 EXCURSION LIMITED 4X4 stroked ts 6 position 4" dp and duals hers now
06 F-250 4x4 6.0 auto lariat crew cab short bed Dads ride
thbd77 is offline  
post #3 of 8 Old 04-11-2010, 12:47 PM Thread Starter
Compression Ignition Addict
 
Join Date: Jan 2010
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by thbd77 View Post
unhook the batteries for 10 to 15 minutes. My dads truck does it every now and then. I believe they say the speedometer cluster is bad.
thanks I'll give it a shot.
ONE_LO_SVT is offline  
post #4 of 8 Old 04-11-2010, 05:40 PM Thread Starter
Compression Ignition Addict
 
Join Date: Jan 2010
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
that did the trick! thanks!
ONE_LO_SVT is offline  
post #5 of 8 Old 04-13-2010, 09:22 PM Thread Starter
Compression Ignition Addict
 
Join Date: Jan 2010
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
well it keeps coming back, which is leading me to believe my speedo is def. defective. what are my options? is ford going to rip me a new one on a replacement?
ONE_LO_SVT is offline  
post #6 of 8 Old 04-19-2010, 05:34 PM
Member
 
Hawgslayer's Avatar
 
Join Date: Apr 2010
Location: Lubbock
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what year model truck is it? Mine did the same, its a 2007
Hawgslayer is offline  
post #7 of 8 Old 04-20-2010, 08:05 PM Thread Starter
Compression Ignition Addict
 
Join Date: Jan 2010
Posts: 281
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
its a 2006 f250 lariet. Its got the nice white faced gauges. The battery trick worked but it starts doing it again pretty soon after. Some trips its works fine, but most it it doesnt. Its frustrating, but i never pay attention to speed limits anyways haha, i know what 40-50 is, and my highway speed is 2000-2500 rpm, 70-78mph.

but would love to know how to fix it. (=
ONE_LO_SVT is offline  
post #8 of 8 Old 12-11-2011, 08:20 PM
Powerstroke.org Rookie
 
Join Date: Dec 2011
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey guys, I have a 07 f-350 and mine does the same thing in cold weather. I've found that if you hold the trip button and turn the key to the on position and release the trip button it will bring up lots of info and the first one is sweeping the gauges.
Johndeere4630 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome