EGR codes - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-08-2010, 10:13 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Posts: 120
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
EGR codes

I know this has probably been discussed more than a few times and I hate to add to it but I have a question involving the 2 codes that I got as soon as I fired my truck up for the first time after deleting the EGR. I bought the truck about 8 months ago its a 2003 and I know I read on some threads before that the 03 and 04 didn't throw the codes but mine did.
P0405 EGR flow sensor a circuit low input
and
P0403 EGR flow circuit malfunction
I remember reading before that you can get a tune for it to solve the problem, is this true and what kind. The truck has the Edge with attitude on it from the previous owner and it works great from what I can tell but it doesn't do any thing to read codes or turn them off like my friend struck. It just monitors the EGTs, RPM, Boost and a box for Backdown, its not just the monitor it has the 5 levels to change like tow and milage etc. This is my first diesel so I'm learning how this stuff works. Please help me out I would be most appreciative for the help, thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-11-2010, 03:44 PM
Banned
 

Join Date: Jan 2010
Location: Southeast Michigan
Posts: 779
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: -1 reviews
on an 03 it shouldnt trip the light with the valve unplugged. if you plug the valve back in, does the light stay off?
Reply With Quote Quick reply to this message
  #3  
Old 04-11-2010, 09:27 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2009
Posts: 120
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Thanks Mastertech for replying. I haven't heard from anyone on this so I have been doing some research on it. I have been told that the reason for it sending a code even though it is an 03 is because it was built for California emissions standards and that is why. I was told the same thing you had mentioned to plug the egr valve back in and try it, I plugged it in(just the wire)and let the valve just sit on the intake not in the intake but the light stayed on. I was out of town for the weekend so tomorrow I will go to my shop and try taking the block off plate off and put the egr valve back in and erase the codes and see if that helps. Will having the valve in make any difference on the truck, being that its all been deleted except for the valve there in the intake? Also I was told that if I get an SCT X3 Tune for my truck it will fix the problem and be a better tune for the truck rather than the Edge system that was on it when I bought it. He said I can still run the Edge programmer but have it on Stock mode or 0 mode with the SCT tune so I can still use the heads up display for the boost, EGT and RPM gauges. How does this sound to you? If your not sure of the answers not problem just wanted to ask so I can rest easy on spending the xtra $ on the SCT tune. I'm one of those who ask alot of questions and research too much before making a plunge. Thats what my wife says
Thanks alot for the response and the help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:53 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors