lost turbo help - Ford Powerstroke Diesel Forum
6.0L Problems Forum Having Trouble? Post here

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-31-2010, 07:10 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jul 2007
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lost turbo help

I just replaced my injector 6 everything went fine. 2 days later I lost turbo! When I removd the value cover there was a tube comeing off the pipe going to the turbo this tube went to a little black box mounted to the top of the value cover this pipe had a o ring. The o ring wouldnt go back on so i left it off could this be the problem every one said this is a vacum system without vac no turbo. Is it this easy
firemantom is offline  
Sponsored Links
post #2 of 2 Old 04-02-2010, 12:59 PM
Join Date: Jan 2010
Location: Southeast Michigan
Posts: 779
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: -1 reviews
that is a crankcase vent system. allows crankcase vapors to be put back through the engine to be reburnt. the oring normally swells and will not go back in. replace oring and all is well. unless it allowed some debris to be ingested into the turbo, it has nothing to do with your turbo.
fordmasterdieseltech is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome